Add two files KURLBlackBerry.cpp and LoggingBlackBerry.cpp to WebCore/platform/blackberry
Created attachment 117346 [details] Patch
Comment on attachment 117346 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=117346&action=review > Source/WebCore/platform/blackberry/KURLBlackBerry.cpp:33 > + return String(path()); KURL::path() returns a string. Therefore, it's sufficient to do: return path(); > Source/WebCore/platform/blackberry/LoggingBlackBerry.cpp:32 > +void InitializeLoggingChannelsIfNecessary() The name of this function doesn't conform to the WebKit Code Style Guidelines. Function names should be in camel case starting with a lowercase letter.
(In reply to comment #2) > (From update of attachment 117346 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=117346&action=review > > > Source/WebCore/platform/blackberry/KURLBlackBerry.cpp:33 > > + return String(path()); > > KURL::path() returns a string. Therefore, it's sufficient to do: > > return path(); OK > > Source/WebCore/platform/blackberry/LoggingBlackBerry.cpp:32 > > +void InitializeLoggingChannelsIfNecessary() > > The name of this function doesn't conform to the WebKit Code Style Guidelines. Function names should be in camel case starting with a lowercase letter. The function name was defined in header file platform/Logging.h, qt/mac/efl/win/wx/gtk all follows. If we fix this style issue, should we do that in a separate PR with all portings changed?
Created attachment 117359 [details] Patch
Created attachment 117379 [details] Patch
Comment on attachment 117379 [details] Patch Clearing flags on attachment: 117379 Committed r102223: <http://trac.webkit.org/changeset/102223>
All reviewed patches have been landed. Closing bug.