Bug 73425 - [GTK] Add an initial jhbuild setup which installs fonts into the WebKitBuild
Summary: [GTK] Add an initial jhbuild setup which installs fonts into the WebKitBuild
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
: 73424 (view as bug list)
Depends on:
Blocks: 73423 73455
  Show dependency treegraph
 
Reported: 2011-11-30 03:29 PST by Martin Robinson
Modified: 2011-11-30 09:23 PST (History)
1 user (show)

See Also:


Attachments
Patch (5.74 KB, patch)
2011-11-30 03:32 PST, Martin Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2011-11-30 03:29:06 PST
The initial jhbuild setup will not include any libraries, but only fonts.
Comment 1 Martin Robinson 2011-11-30 03:32:08 PST
Created attachment 117164 [details]
Patch
Comment 2 Martin Robinson 2011-11-30 03:33:52 PST
*** Bug 73424 has been marked as a duplicate of this bug. ***
Comment 3 Gustavo Noronha (kov) 2011-11-30 06:18:05 PST
Comment on attachment 117164 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=117164&action=review

Looks great =)

> Tools/Scripts/update-webkitgtk-libs:24
> +# Execute gclient sync.

Lies! maybe just remove the comment?
Comment 4 Gustavo Noronha (kov) 2011-11-30 09:04:53 PST
Comment on attachment 117164 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=117164&action=review

> Tools/Scripts/update-webkitgtk-libs:28
> +system(@jhbuildArgs);

Like we discussed, we should exit with the value returned by system to make the step fail if jhbuild fails.
Comment 5 Martin Robinson 2011-11-30 09:17:07 PST
Committed r101523: <http://trac.webkit.org/changeset/101523>