Bug 7323 - REGRESSION (10.4.4): ondrag* events don't fire on page in a frame
Summary: REGRESSION (10.4.4): ondrag* events don't fire on page in a frame
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords: HasReduction, InRadar, Regression
: 9056 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-17 04:01 PST by Adam Blomberg
Modified: 2006-12-18 11:50 PST (History)
7 users (show)

See Also:


Attachments
A document (211 bytes, text/html)
2006-02-17 04:03 PST, Adam Blomberg
no flags Details
A frameset (68 bytes, text/html)
2006-02-17 04:04 PST, Adam Blomberg
no flags Details
Frameset (81 bytes, text/html)
2006-02-17 14:21 PST, Joost de Valk (AlthA)
no flags Details
test case for ondragover and ondragleave in Safari 2.0.2 and 2.0.3/2.0.4 (6.33 KB, application/octet-stream)
2006-07-20 00:12 PDT, Thomas Schumann
no flags Details
proposed fix (35.26 KB, patch)
2006-10-29 05:10 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff
proposed fix (46.49 KB, patch)
2006-10-29 22:52 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff
proposed fix (46.58 KB, patch)
2006-11-01 22:24 PST, Alexey Proskuryakov
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Blomberg 2006-02-17 04:01:59 PST
The events ondragover, ondragenter, ondragleave (and ondrop) don't fire on elements in a document  viewed in a frame. When viewing the same document in a stand-alone window, the events do fire.
Comment 1 Adam Blomberg 2006-02-17 04:03:21 PST
Created attachment 6560 [details]
A document

A document. Displays JavaScript alerts when the link is dragged over the text "...here".
Comment 2 Adam Blomberg 2006-02-17 04:04:35 PST
Created attachment 6561 [details]
A frameset

A frameset. When the previously attached document is viewed within this frame, the drag events don't fire
Comment 3 Joost de Valk (AlthA) 2006-02-17 14:08:44 PST
Could you attach a working frameset testcase? :) thx!
Comment 4 Joost de Valk (AlthA) 2006-02-17 14:21:44 PST
Created attachment 6568 [details]
Frameset
Comment 5 Joost de Valk (AlthA) 2006-02-17 14:22:20 PST
Did it myself :) testcase confirms the behavior.
Comment 6 Thomas Schumann 2006-05-17 03:26:08 PDT
Hello, 

we used this features in some big picture workflow webapplikations and we have also trouble with this. We have created a safari package, which used the older webkit from mac OSX 10.4.3.
But this can be for us only a short workaround.

I'm hope that's the ondrag* functions soon works again in frames.

I has posting the bug by burgreport.apple.com. There is also a testcase. Bugreport there ist 4504308. 

Can you give us a prognosis for bugfix?

Kindest regards

Thomas Schumann

Dresden 
GERMANY
Comment 7 Alexey Proskuryakov 2006-05-17 09:48:58 PDT
(In reply to comment #6)
> We have created a safari package, which used the older webkit from mac OSX 10.4.3.

Do you mean that this worked in 10.4.3, and broke starting with 10.4.4?? The report doesn't mention this.
Comment 8 Thomas Schumann 2006-05-18 00:14:39 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > We have created a safari package, which used the older webkit from mac OSX 10.4.3.
> Do you mean that this worked in 10.4.3, and broke starting with 10.4.4?? The
> report doesn't mention this.

Hello,
first, sorry for my bad english...
This is the situation:
- ondrag* events worked in OSX 10.4.3 with Safari 2.0.2 also in framesets.
- ondrag* events don't work in OSX 10.4.4 in framesets, only of the self page, where is started the event

As workaround for our customer, we has created a safari 2.0.2 package with included webkit framework from mac OSX 10.4.3. (see www.michelf.com/weblog/2005/mutli-safari) . This "personal" Safari can used also in 10.4.4, separately to Safari 2.0.3.
But this can be only a temporarly workaround.
Thomas Schumann
Dresden
GERMANY

Comment 9 Alexey Proskuryakov 2006-05-18 00:35:46 PDT
Thank you for the clarification! Based on this additional information, I'm marking the bug as Regression/P1.
Comment 10 Thomas Schumann 2006-05-18 01:55:08 PDT
(In reply to comment #9)
> Thank you for the clarification! Based on this additional information, I'm
> marking the bug as Regression/P1.

Fine! Can I hope so, the bug are fixed in the (near) future?
Kindest regards
Thomas Schumann
Comment 11 Alexey Proskuryakov 2006-07-19 11:37:56 PDT
What is the expected behavior here? I can see that ondragenter works in WinIE, but other events don't (even when not in a subframe).
Comment 12 Alexey Proskuryakov 2006-07-19 11:51:48 PDT
Filed bug 10011 for an unrelated issue (assertion failure) discovered with this test case.
Comment 13 Thomas Schumann 2006-07-20 00:12:52 PDT
Created attachment 9580 [details]
test case for ondragover and ondragleave in Safari 2.0.2 and 2.0.3/2.0.4

I don't understand you. We have no problems in WinIE, but in Safari 2.0.3 and higher !! 

In Safari 2.0.2 works ondragover and ondragleave in single html-sites AND framesets.
Under Safari 2.0.3 works ONLY in single html-sites. We have programmed some web-applikations and need's the feature in framesets again.

Here a zip with a simple test case (3 html-sites and 2 pictures).
Load the frameset.html and drag the blue picture over picture2 in left or right frame. In safari 2.0.2 you see a alert-Messagebox "ondragover" or "ondragleave". In safari 2.0.3) you don't see the message.

Load only the left.html and drag the blue picture over picture2.
In safari 2.0.2 AND in safari 2.0.3 you see the alert.

Thanks for reply

Thomas Schumann
Comment 14 Alexey Proskuryakov 2006-07-20 03:54:56 PDT
(In reply to comment #13)
> I don't understand you. We have no problems in WinIE, but in Safari 2.0.3 and
> higher !! 

Thank you for the new test case - it clarifies a lot! Please note that the original test case for this bug doesn't fully work in WinIE (probably because <p> is used there, rather than <img>) - this was the reason for my confusion.
Comment 15 Thomas Schumann 2006-07-20 04:20:03 PDT
(In reply to comment #14)
> Thank you for the new test case - it clarifies a lot! Please note that the
> original test case for this bug doesn't fully work in WinIE (probably because
> <p> is used there, rather than <img>) - this was the reason for my confusion.

Fine. In the moment we have 3 big web-applikation installations, which are using ondrag* events. 
The discussions with our customers, why safari 2.0.2 and not a current safari version, is a very big problem for us. We needs your help...
Kindest regards
Thomas Schumann
Comment 16 Alexey Proskuryakov 2006-10-26 13:19:54 PDT
I have a fix, now struggling with DumpRenderTree to make a test (its dragging delegate does strange things).
Comment 17 Alexey Proskuryakov 2006-10-29 05:10:15 PST
Created attachment 11274 [details]
proposed fix
Comment 18 Alexey Proskuryakov 2006-10-29 11:57:40 PST
Comment on attachment 11274 [details]
proposed fix

Hmm, now that layout tests work again, I see some unexpected failures - will need to investigate.
Comment 19 Alexey Proskuryakov 2006-10-29 22:52:27 PST
Created attachment 11281 [details]
proposed fix

All layout tests pass now.
Comment 20 Alexey Proskuryakov 2006-11-01 22:24:49 PST
Created attachment 11343 [details]
proposed fix

Updated to cleanly apply to current trunk.

Factored out [EventSendingController saveEvent:], as suggested by Mitz (and tested that the patch doesn't break <input type=search> in subframes).
Comment 21 Adele Peterson 2006-11-03 00:18:03 PST
Comment on attachment 11343 [details]
proposed fix

looks good.  editing/selection/select-from-textfield-outwards.html has some commented alerts that can be removed.  r=me, nice job!
Comment 22 Timothy Hatcher 2006-11-03 10:47:38 PST
Landed in r17574
Comment 23 Thomas Schumann 2006-11-03 12:41:40 PST
(In reply to comment #22)
> Landed in r17574


Is the fix available in the next safari-update?
I hope so...

Thank you for work.
Best regards
Thomas

Comment 24 Alexey Proskuryakov 2006-11-03 12:46:54 PST
(In reply to comment #23)
> Is the fix available in the next safari-update?

Most likely, no-one here will be able to answer this - open source contributors have nothing to do with releases from Apple, Omni, Adobe or other vendors, and Apple developers are generally not allowed to discuss future releases.

You may try asking via official channels (http://bugreport.apple.com and DTS).
Comment 25 Thomas Schumann 2006-11-03 12:54:54 PST
Thanks, but is the fix included in the next webkit-Package?

I will make a official entry in the bugreport of apple. There is the problem already known.

Have a nice evening.
Thomas

Comment 26 Alexey Proskuryakov 2006-11-03 13:01:01 PST
(In reply to comment #25)
> Thanks, but is the fix included in the next webkit-Package?

Are you asking about nightly builds from http://nightly.webkit.org? The fix is not yet there at the moment (the latest build is r17566, while the fix was landed in r17574), but it will be soon. Please let us know how it works!
Comment 27 David Kilzer (:ddkilzer) 2006-11-03 13:15:09 PST
(In reply to comment #25)
> I will make a official entry in the bugreport of apple. There is the problem
> already known.

Per Comment #6, there is already a Radar bug for this, so no need to file another one:  rdar://problem/4504308.  If you haven't mentioned that this regression occurred in Safari 2.0.3 in Mac OS X 10.4.4 in that bug, I would definitely do that.

Apple doesn't comment on future product releases (except iTV), so there's no telling when this bug will be fixed, but I'm sure the Safari team will be very interested in regressions introduced in a Tiger update.
Comment 28 Thomas Schumann 2006-11-04 00:31:05 PST
I have not found Version r17566. 
But i have tested with latest version r17587 (is this correct?).
There ist the functionality back, super!!
What can i do now? Awaiting of fix implementation in the next Tiger update from apple team (how David Kilzer wrote)?
Best regards
Thomas
Comment 29 Alexey Proskuryakov 2006-11-05 03:05:13 PST
This has caused a regression in plugin event dispatching, bug 11517.
Comment 30 mitz 2006-12-18 11:50:23 PST
*** Bug 9056 has been marked as a duplicate of this bug. ***