Bug 7320 - Animated GIFs animate very slowly
Summary: Animated GIFs animate very slowly
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 417.x
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.coopersport.ca/banners/Coo...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2006-02-16 21:19 PST by Jason Chiovitti
Modified: 2008-03-23 20:32 PDT (History)
3 users (show)

See Also:


Attachments
Looping animated gif example (544.96 KB, image/gif)
2008-03-23 17:26 PDT, Lewis Francis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Chiovitti 2006-02-16 21:19:20 PST
Seems to effect OSX 10.4.x with Safari 2.x as well as iChat 3.x or other applications using the same rendering engine. Effects both PowerPC and Universal builds. Not sure if this only effects Animated GIFS created with Adobe ImageReady.

Example can be seen in the Animated GIF located here...

http://www.coopersport.ca/banners/Coopersport_Ani1.gif

Proper rendering can be seen using OSX versions of Firefox or Explorer.
Comment 1 Joost de Valk (AlthA) 2006-02-17 14:41:54 PST
Confirmed, Hyatt has been busy in this area lately, cc-ing him, perhaps he knows how to solve this. Gonna check if this is a regression as well.
Comment 2 Joost de Valk (AlthA) 2006-02-17 14:42:43 PST
This is NOT a regression, it was slow in released Safari as well.
Comment 3 Dave Hyatt 2006-02-17 16:14:00 PST
This is a bug in ImageIO.  It works fine with the Win32 Cairo decoder.  I will file a bug in Radar and then we can close this out.

Comment 4 lacerchia 2007-11-21 03:08:42 PST
This bug still affects Safari 3.0.4 on Mac OS X 10.4. I'm not sure about 10.5, but I doubt the ImageIO bug is going to be fixed in 10.4 now. Isn't it possible to use a different decoder/renderer for GIFs, at least in 10.4? The code used in Safari 1.x on OS X 10.3 didn't have this issue; perhaps it's time to resurrect it.
Comment 5 Alexey Proskuryakov 2007-11-21 05:53:25 PST
The original test case is not available at bug URL anymore, we cannot proceed without a test case.
Comment 6 Lewis Francis 2008-03-23 17:26:02 PDT
Created attachment 19989 [details]
Looping animated gif example
Comment 7 Lewis Francis 2008-03-23 17:27:06 PDT
Comment on attachment 19989 [details]
Looping animated gif example

Slow animated gif performance on all Safari 3+, Tiger, Leopard, and WinXP.
Comment 8 Dave Hyatt 2008-03-23 20:08:09 PDT
I believe this is a bug in the Image I/O framework and not a WebKit bug.  This could be confirmed by testing this image in the GTK or Qt  or wx ports of WebKit.
Comment 9 Mark Rowe (bdash) 2008-03-23 20:11:10 PDT
<rdar://problem/5815212>
Comment 10 Dave Hyatt 2008-03-23 20:32:14 PDT
I am closing this bug, as it is not a bug in WebKit itself (and therefore will be tracked in Radar instead of here).