Bug 73196 - Upstream platform/network/blackberry/AuthenticationChallenge.h
: Upstream platform/network/blackberry/AuthenticationChallenge.h
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Leo Yang
:
Depends on:
Blocks: 73144
  Show dependency treegraph
 
Reported: 2011-11-28 01:30 PST by Leo Yang
Modified: 2011-11-28 18:18 PST (History)
6 users (show)

See Also:


Attachments
Patch (4.04 KB, patch)
2011-11-28 01:59 PST, Leo Yang
zimmermann: review+
dbates: commit‑queue-
Details | Formatted Diff | Diff
Patch v2 (4.10 KB, patch)
2011-11-28 17:49 PST, Leo Yang
dbates: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Yang 2011-11-28 01:30:08 PST
This is to upstream the BlackBerry porting of AuthenticationChallenge.h.
Comment 1 Leo Yang 2011-11-28 01:59:21 PST
Created attachment 116713 [details]
Patch
Comment 2 Nikolas Zimmermann 2011-11-28 06:55:04 PST
Comment on attachment 116713 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=116713&action=review

r=me.

> Source/WebCore/platform/network/blackberry/AuthenticationChallenge.h:43
> +    // If attached credentials stored in CredentialStorage.

"Describes if the attached credentials are stored in CredentialStorage."
We should use full sentences.
Comment 3 Daniel Bates 2011-11-28 08:58:27 PST
Comment on attachment 116713 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=116713&action=review

> Source/WebCore/ChangeLog:10
> +        This is the BlackBerry implementation of WebCore::AuthenticationChallenge.
> +
> +        Other contributors:
> +        Jason C Chan <jasochan@rim.com>
> +        Jakob Petsovits <jpetsovits@rim.com>

This should be moved so that it comes after the Reviewed by line.

> Source/WebCore/platform/network/blackberry/AuthenticationChallenge.h:47
> +}

This file is short. That being said, we usually write an inline comment here, // namespace WebCore, to demarcate the end of the WebCore namespace.

> Source/WebCore/platform/network/blackberry/AuthenticationChallenge.h:49
> +#endif

This file is short. That being said, we usually write an inline comment here, // AuthenticationChallenge_h, to demarcate the end of the #ifndef.
Comment 4 Leo Yang 2011-11-28 17:49:41 PST
Created attachment 116861 [details]
Patch v2

Not set commit-queue? because cq seems slow and the patch will bring no regression. I'll commit it manually.
Comment 5 Leo Yang 2011-11-28 18:18:20 PST
Committed r101312: <http://trac.webkit.org/changeset/101312>