Bug 73024 - Web Inspector: get rid of the WebInspector.mainResource, use WebInspector.inspectedPageURL instead.
Summary: Web Inspector: get rid of the WebInspector.mainResource, use WebInspector.ins...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-23 09:14 PST by Pavel Feldman
Modified: 2011-11-24 00:11 PST (History)
10 users (show)

See Also:


Attachments
Patch (25.20 KB, patch)
2011-11-23 09:17 PST, Pavel Feldman
yurys: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2011-11-23 09:14:27 PST
We use it for the URL mostly, no need to create artificial resource for that upon attaching to the existing page.
Comment 1 Pavel Feldman 2011-11-23 09:17:09 PST
Created attachment 116373 [details]
Patch
Comment 2 Yury Semikhatsky 2011-11-23 09:26:01 PST
Comment on attachment 116373 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=116373&action=review

> Source/WebCore/inspector/front-end/AuditsPanel.js:135
> +        var mainResourceURL = WebInspector.inspectedPageURL;

I don't think inspectedPageUrl is a good name, it will be confusing in case of worker inspector, could you rename it to mainResourceURL or something like that? Same for inspectedPageDomain
Comment 3 Vsevolod Vlasov 2011-11-23 17:35:28 PST
Comment on attachment 116373 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=116373&action=review

> Source/WebCore/inspector/front-end/NetworkPanel.js:986
> +        InspectorFrontendHost.saveAs(WebInspector.inspectedPageURL.asParsedURL().host + ".har", JSON.stringify(harArchive));

s/WebInspector.inspectedPageURL.asParsedURL().host/WebInspector.inspectedPageDomain/
Comment 4 Pavel Feldman 2011-11-24 00:11:26 PST
Committed r101126: <http://trac.webkit.org/changeset/101126>