Bug 72743 - [WK2] Bring web notification support to WK2
: [WK2] Bring web notification support to WK2
Status: RESOLVED DUPLICATE of bug 73253
: WebKit
WebKit2
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To:
:
: InRadar
:
:
  Show dependency treegraph
 
Reported: 2011-11-18 11:12 PST by
Modified: 2011-12-19 11:20 PST (History)


Attachments
JSC/WebCore changes (40.43 KB, patch)
2011-11-18 13:39 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
WebKit changes (16.98 KB, patch)
2011-11-18 13:41 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
WebKit2 changes (82.83 KB, patch)
2011-11-18 13:42 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
Attempt to make bots happy (140.35 KB, patch)
2011-11-22 21:08 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
Attempt to make bots happy #2 (147.03 KB, patch)
2011-11-28 12:00 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
Attempt to make bots happy #3 (151.61 KB, patch)
2011-11-28 13:39 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff
Attempt to make bots happy #4 (153.76 KB, patch)
2011-11-28 14:03 PST, Jon Lee
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-11-18 11:12:40 PST
<rdar://problem/10356943>
------- Comment #1 From 2011-11-18 13:39:23 PST -------
Created an attachment (id=115863) [details]
Patch
------- Comment #2 From 2011-11-18 13:41:12 PST -------
Created an attachment (id=115865) [details]
WebKit changes
------- Comment #3 From 2011-11-18 13:41:16 PST -------
Attachment 115863 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/WebCore/notifications/NotificationController.h:35:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/WebCore/notifications/NotificationContents.h:44:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/notifications/NotificationContents.h:49:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/notifications/Notification.h:64:  The parameter name "url" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/Notification.h:64:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/Notification.h:64:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/Notification.h:65:  The parameter name "contents" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/Notification.h:65:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/Notification.h:65:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/notifications/NotificationPresenter.h:61:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Source/WebCore/notifications/NotificationPresenter.h:77:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/notifications/NotificationCenter.h:81:  The parameter name "callback" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 12 in 15 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #4 From 2011-11-18 13:42:04 PST -------
Created an attachment (id=115866) [details]
WebKit2 changes
------- Comment #5 From 2011-11-18 13:43:14 PST -------
I tried to break out this really large patch based on project for easier reviewing. While uploading it caught a bunch of style-related bugs which I intend on fixing when I submit. It's just a little difficult to do that with the way the code changes are set up on my local machine.
------- Comment #6 From 2011-11-18 13:43:56 PST -------
Attachment 115865 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit/ChangeLog', u'Source/WebKit/..." exit_code: 1

Source/WebKit/mac/WebCoreSupport/WebNotificationClient.h:29:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Total errors found: 1 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #7 From 2011-11-18 13:45:35 PST -------
Attachment 115866 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1

Source/WebKit2/UIProcess/API/C/WKNotificationManager.cpp:30:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebKit2/WebProcess/WebCoreSupport/WebNotificationClient.h:34:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/WebKit2/WebProcess/WebCoreSupport/WebNotificationClient.h:43:  This { should be at the end of the previous line  [whitespace/braces] [4]
Source/WebKit2/WebProcess/WebCoreSupport/WebNotificationClient.h:45:  The parameter name "page" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/WebNotificationManagerProxy.h:53:  The parameter name "provider" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/API/C/WKNotificationManager.h:30:  Alphabetical sorting problem.  [build/include_order] [4]
Total errors found: 6 in 38 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #8 From 2011-11-18 14:26:58 PST -------
(From update of attachment 115863 [details])
Attachment 115863 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/10519213
------- Comment #9 From 2011-11-18 14:27:37 PST -------
(From update of attachment 115863 [details])
Attachment 115863 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/10495224
------- Comment #10 From 2011-11-18 14:30:46 PST -------
(From update of attachment 115865 [details])
Attachment 115865 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/10515204
------- Comment #11 From 2011-11-18 17:57:24 PST -------
(From update of attachment 115866 [details])
Attachment 115866 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/10517296
------- Comment #12 From 2011-11-22 21:08:26 PST -------
Created an attachment (id=116315) [details]
Attempt to make bots happy
------- Comment #13 From 2011-11-22 21:19:02 PST -------
(From update of attachment 116315 [details])
Attachment 116315 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/10616115
------- Comment #14 From 2011-11-22 21:29:57 PST -------
(From update of attachment 116315 [details])
Attachment 116315 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/10602164
------- Comment #15 From 2011-11-23 03:30:19 PST -------
(From update of attachment 116315 [details])
Attachment 116315 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/10602275
------- Comment #16 From 2011-11-28 12:00:36 PST -------
Created an attachment (id=116797) [details]
Attempt to make bots happy #2
------- Comment #17 From 2011-11-28 13:39:26 PST -------
Created an attachment (id=116810) [details]
Attempt to make bots happy #3
------- Comment #18 From 2011-11-28 13:45:23 PST -------
(From update of attachment 116810 [details])
Attachment 116810 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/10678398
------- Comment #19 From 2011-11-28 13:50:59 PST -------
(From update of attachment 116810 [details])
Attachment 116810 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/10664832
------- Comment #20 From 2011-11-28 14:03:00 PST -------
Created an attachment (id=116816) [details]
Attempt to make bots happy #4
------- Comment #21 From 2011-11-28 15:15:12 PST -------
Splitting the task out a little bit for easier committing.
------- Comment #22 From 2011-11-28 17:32:12 PST -------
Actually never mind. I got my bug organization all wrong. 73253 is this bug. Since I made the mistake of committing it in the other bug, I will mark this as a dupe of 73253 and remove the blocking relationship. Sorry for the confusion.

*** This bug has been marked as a duplicate of bug 73253 ***
------- Comment #23 From 2011-12-19 11:20:40 PST -------
(From update of attachment 116816 [details])
Cleared review? from attachment 116816 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).