Bug 72393 - Web Inspector: introduce Debugger domain capabilities concept.
Summary: Web Inspector: introduce Debugger domain capabilities concept.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-15 09:50 PST by Pavel Feldman
Modified: 2011-11-17 15:48 PST (History)
14 users (show)

See Also:


Attachments
Patch (18.84 KB, patch)
2011-11-15 10:00 PST, Pavel Feldman
yurys: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2011-11-15 09:50:51 PST
Many of the Preferences that we have in Settings.js and override in DevTools.js are really not preferences, but capabilities. Protocol clients should have a way of figuring out whether some capability is present before using it. I'm adding the "capability" concept into the JSON and Debugger::getCapabilities as the first implementation. Marked as hidden so far.
Comment 1 Pavel Feldman 2011-11-15 10:00:12 PST
Created attachment 115185 [details]
Patch
Comment 2 WebKit Review Bot 2011-11-15 10:04:51 PST
Attachment 115185 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/inspector/InspectorDebuggerAgent.cpp:103:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorDebuggerAgent.h:67:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 2 in 12 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Yury Semikhatsky 2011-11-16 23:27:09 PST
Comment on attachment 115185 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=115185&action=review

> Source/WebCore/bindings/v8/ScriptDebugServer.cpp:43
> +#include <wtf/Vector.h>

remove this

> Source/WebCore/bindings/v8/ScriptDebugServer.h:44
> +#include <wtf/Vector.h>

remove this

> Source/WebCore/inspector/Inspector.json:1797
> +                "name": "getCapabilities",

Should we have a separate command getCapabilities([domain]) instead of introducing it on each agent?
Comment 4 Pavel Feldman 2011-11-17 00:17:02 PST
Committed r100572: <http://trac.webkit.org/changeset/100572>
Comment 5 Peter Kasting 2011-11-17 13:51:31 PST
This may have caused bug 72651.  I'm going to try rolling out r100572 to see if the Linux dbg bot stabilizes.
Comment 6 Peter Kasting 2011-11-17 15:48:08 PST
The rollout did not help, so I'm rolling this change back in.