Bug 71766 - [Qt] svg/custom/getBBox-path.svg fails
Summary: [Qt] svg/custom/getBBox-path.svg fails
Status: RESOLVED DUPLICATE of bug 99471
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 53512
  Show dependency treegraph
 
Reported: 2011-11-07 22:23 PST by Csaba Osztrogonác
Modified: 2012-10-16 11:38 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-11-07 22:23:17 PST
svg/custom/getBBox-path.svg introduced in http://trac.webkit.org/changeset/99460,
but fails on Qt:

--- /ramdisk/qt-linux-64-release/build/layout-test-results/svg/custom/getBBox-path-expected.txt 
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/svg/custom/getBBox-path-actual.txt 
@@ -1,1 +1,1 @@
-100 37.5 PASS
+100 50 FAIL
Comment 1 Rob Buis 2012-04-30 14:58:23 PDT
This is because QPainterPath::controlPointRect() is used instead of QPainterPath::boundingRect()
Comment 2 Csaba Osztrogonác 2012-05-02 01:22:29 PDT
(In reply to comment #1)
> This is because QPainterPath::controlPointRect() is used instead of QPainterPath::boundingRect()

Reni, Zoltán, could fix it?
Comment 3 Allan Sandfeld Jensen 2012-10-16 09:35:36 PDT
I accidentally created a new bug for the patch to this problem. See bug #99471

*** This bug has been marked as a duplicate of bug 99471 ***
Comment 4 Csaba Osztrogonác 2012-10-16 11:38:53 PDT
(In reply to comment #3)
> I accidentally created a new bug for the patch to this problem. See bug #99471
> 
> *** This bug has been marked as a duplicate of bug 99471 ***

I unskipped the test - r131480