RESOLVED FIXED 71736
Allow gamepad to be enabled at runtime
https://bugs.webkit.org/show_bug.cgi?id=71736
Summary Allow gamepad to be enabled at runtime
Scott Graham
Reported 2011-11-07 14:57:49 PST
Add runtime enable for gamepad functionality. Full patch here https://bugs.webkit.org/show_bug.cgi?id=69451
Attachments
Patch (2.61 KB, patch)
2011-11-07 14:59 PST, Scott Graham
no flags
consistently plural (2.62 KB, patch)
2011-11-07 15:07 PST, Scott Graham
no flags
less ungrammatical (2.61 KB, patch)
2011-11-07 15:33 PST, Scott Graham
no flags
Scott Graham
Comment 1 2011-11-07 14:59:47 PST
Scott Graham
Comment 2 2011-11-07 15:07:11 PST
Created attachment 113937 [details] consistently plural
Adam Barth
Comment 3 2011-11-07 15:24:32 PST
Comment on attachment 113937 [details] consistently plural View in context: https://bugs.webkit.org/attachment.cgi?id=113937&action=review > Source/WebCore/bindings/generic/RuntimeEnabledFeatures.cpp:64 > +bool RuntimeEnabledFeatures::isGamepadsEnabled = false; "is gamepads" ? :( Can we change this to isGamepadEnabled ?
Scott Graham
Comment 4 2011-11-07 15:27:53 PST
Comment on attachment 113937 [details] consistently plural View in context: https://bugs.webkit.org/attachment.cgi?id=113937&action=review >> Source/WebCore/bindings/generic/RuntimeEnabledFeatures.cpp:64 >> +bool RuntimeEnabledFeatures::isGamepadsEnabled = false; > > "is gamepads" ? :( > > Can we change this to isGamepadEnabled ? Yes, it's ugly and ungrammatical. :( gamepadsEnabled() has to be plural because of the binding generation code. So I waffled for a while and went full-plural. Would you like to see just the bool singular? Or both the bool and the setGamepad[s]Enabled function as singular (but not matching the get)?
Scott Graham
Comment 5 2011-11-07 15:32:31 PST
(In reply to comment #4) > (From update of attachment 113937 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=113937&action=review > > >> Source/WebCore/bindings/generic/RuntimeEnabledFeatures.cpp:64 > >> +bool RuntimeEnabledFeatures::isGamepadsEnabled = false; > > > > "is gamepads" ? :( > > > > Can we change this to isGamepadEnabled ? > > Yes, it's ugly and ungrammatical. :( > > gamepadsEnabled() has to be plural because of the binding generation code. So I waffled for a while and went full-plural. Would you like to see just the bool singular? Or both the bool and the setGamepad[s]Enabled function as singular (but not matching the get)? Hmm, actually I guess setGamepadsEnabled sounds OK. It just seemed awkward to have that modify a bool that was singular. I'll do that.
Scott Graham
Comment 6 2011-11-07 15:33:42 PST
Created attachment 113942 [details] less ungrammatical
Adam Barth
Comment 7 2011-11-07 15:35:42 PST
Comment on attachment 113942 [details] less ungrammatical Ok. We really should just autogenerate this file.
WebKit Review Bot
Comment 8 2011-11-07 16:27:59 PST
Comment on attachment 113942 [details] less ungrammatical Clearing flags on attachment: 113942 Committed r99500: <http://trac.webkit.org/changeset/99500>
WebKit Review Bot
Comment 9 2011-11-07 16:28:04 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.