Bug 71734 - The Full Keyboard Access preference should be read in the UI process
Summary: The Full Keyboard Access preference should be read in the UI process
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-11-07 14:23 PST by Alexey Proskuryakov
Modified: 2011-11-07 14:53 PST (History)
0 users

See Also:


Attachments
proposed patch (30.21 KB, patch)
2011-11-07 14:33 PST, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2011-11-07 14:23:18 PST
That would let us tighten the sandbox a bit. Also, that's what we do for other global preferences.

<rdar://problem/9237619>
Comment 1 Alexey Proskuryakov 2011-11-07 14:33:04 PST
Created attachment 113931 [details]
proposed patch
Comment 2 Darin Adler 2011-11-07 14:41:38 PST
Comment on attachment 113931 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=113931&action=review

> Source/WebKit2/WebProcess/WebProcess.h:99
> +    bool fullKeyboardAccessEnabled() { return m_fullKeyboardAccessEnabled; }

Maybe make this const?

> Source/WebKit2/WebProcess/WebProcess.h:146
> +    void fullKeyboardAccessModeChanged(bool mode);

The word “mode” is not a great name for this argument. Maybe “fullKeyboardAcessEabled”?

I’m not sure that xxxChanged is a great name for something that just sets the mode. I think setFullKeyboardAccessEnabled is a better name.
Comment 3 Alexey Proskuryakov 2011-11-07 14:53:31 PST
Committed <http://trac.webkit.org/changeset/99483>.

> Maybe make this const?

Done.

> The word “mode” is not a great name for this argument. Maybe “fullKeyboardAcessEabled”?

Done.

> I’m not sure that xxxChanged is a great name for something that just sets the mode. I think setFullKeyboardAccessEnabled is a better name.

I agree that it's slightly better from WebProcess perspective. However, I wanted to keep it consistent with LanguageChanged.