Bug 71266 - CSS2:text-decoration: <rt> element should not inherit text-decoration property
: CSS2:text-decoration: <rt> element should not inherit text-decoration property
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.5
: P3 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 23:16 PDT by Hiroshi Takase
Modified: 2012-02-23 15:55 PST (History)
7 users (show)

See Also:


Attachments
HTML source (684 bytes, text/html)
2011-10-31 23:16 PDT, Hiroshi Takase
no flags Details
Prevent text-decoration propagation for rt tag if it has its default treatment of block (4.64 KB, patch)
2012-02-16 21:42 PST, Koji Ishii
no flags Details | Formatted Diff | Diff
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block (4.47 KB, patch)
2012-02-22 03:37 PST, Koji Ishii
no flags Details | Formatted Diff | Diff
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block (5.30 KB, patch)
2012-02-23 00:01 PST, Koji Ishii
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroshi Takase 2011-10-31 23:16:40 PDT
Created attachment 113132 [details]
HTML source

Text-decoration property does not inherit.  So <rt> element should not be underlined if <rt> element itself is not specified "text-decoration" property and the parent element is specified "text-decoration:underline".
Comment 1 Koji Ishii 2011-11-01 20:52:53 PDT
Here's the discussion on this at www-style:
http://lists.w3.org/Archives/Public/www-style/2011Sep/0238.html
Comment 2 Koji Ishii 2012-02-14 12:53:05 PST
I'd like to work on this one.
Comment 3 Koji Ishii 2012-02-16 21:42:23 PST
Created attachment 127519 [details]
Prevent text-decoration propagation for rt tag if it has its default treatment of block

Turned out that the diff is just one line. A new reftest is included.
Comment 4 Koji Ishii 2012-02-17 01:44:28 PST
Now I wonder, maybe tests should be in fast/ruby instead of fast/css, because the test requires ruby and CSS2. Any suggestions appreciated.
Comment 5 Koji Ishii 2012-02-21 21:11:06 PST
Comment on attachment 127519 [details]
Prevent text-decoration propagation for rt tag if it has its default treatment of block

I'd like to take a different approach.
Comment 6 Koji Ishii 2012-02-21 21:48:45 PST
In bug 18611, the fix is made to RenderObject::getTextDecorationColors. Which is the correct place to fix?
Comment 7 Koji Ishii 2012-02-22 03:37:36 PST
Created attachment 128170 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Previous patch modified CSSStyleSelector::adjustRenderStyle, but I found a similar bug 18611, which fixes RenderObject::getTextDecorationColors instead, so this patch follows that.

Two things are different from the previous patch:
* The check is slightly faster than the previous patch (one virtual call on paint(), while the previous patch checks two fields on attach().)
* The -webkit-text-decoration-in-effect was not set in the previous patch, but is set in this patch.

reftest is included. This is slightly improved from the previous patch.
Comment 8 Koji Ishii 2012-02-22 23:34:26 PST
Comment on attachment 128170 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Could someone please review this patch?
Comment 9 Kentaro Hara 2012-02-22 23:46:27 PST
Comment on attachment 128170 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

View in context: https://bugs.webkit.org/attachment.cgi?id=128170&action=review

> Source/WebCore/ChangeLog:7
> +

Would you please add the link to the spec that supports this change?
Comment 10 Koji Ishii 2012-02-23 00:01:38 PST
Created attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Added the link to the spec that supports this change, and also to a discussion at www-style to confirm it to the ChangeLogs.
Comment 11 Kentaro Hara 2012-02-23 00:14:02 PST
Comment on attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Makes sense!
Comment 12 WebKit Review Bot 2012-02-23 02:15:14 PST
Comment on attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Rejecting attachment 128416 [details] from review queue.

haraken@chromium.org does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have reviewer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have reviewer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your reviewer rights.
Comment 13 Kentaro Hara 2012-02-23 02:22:59 PST
Just right now something wrong seems to be happening on the WebKit svn server. Let me commit it again after the issue is solved.
Comment 14 WebKit Review Bot 2012-02-23 07:42:54 PST
Comment on attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Rejecting attachment 128416 [details] from review queue.

haraken@chromium.org does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have reviewer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have reviewer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your reviewer rights.
Comment 15 Kentaro Hara 2012-02-23 15:28:56 PST
Comment on attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

It seems strange. As far as I see committers.py, I am in the reviewer list and no change had been made to the list recently. Let me try r+ again.
Comment 16 WebKit Review Bot 2012-02-23 15:55:34 PST
Comment on attachment 128416 [details]
patch: Prevent text-decoration propagation for rt tag if it has its default treatment of block

Clearing flags on attachment: 128416

Committed r108690: <http://trac.webkit.org/changeset/108690>
Comment 17 WebKit Review Bot 2012-02-23 15:55:40 PST
All reviewed patches have been landed.  Closing bug.