Bug 71177 - Assert failure in WebCore::HTMLFrameElementBase::insertedIntoDocument()
Summary: Assert failure in WebCore::HTMLFrameElementBase::insertedIntoDocument()
Status: RESOLVED DUPLICATE of bug 50312
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P2 Normal
Assignee: Nobody
URL: http://jezebel.com/5660461/a-day-in-t...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-29 09:41 PDT by Dimitris Apostolou
Modified: 2012-01-03 13:39 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Apostolou 2011-10-29 09:41:23 PDT
r98805

Reproducibility: always

Steps:
Go to http://jezebel.com/5660461/a-day-in-the-life-of-a-paparazzo

What happened:
Assert failure.

ASSERTION FAILED: !renderer()
/Users/rex/WebKit/Source/WebCore/html/HTMLFrameElementBase.cpp(212) : virtual void WebCore::HTMLFrameElementBase::insertedIntoDocument()
1   0x109b8ee61 WebCore::HTMLFrameElementBase::insertedIntoDocument()
2   0x109b93a97 WebCore::HTMLIFrameElement::insertedIntoDocument()
3   0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
4   0x10999f3ef WebCore::Element::insertedIntoDocument()
5   0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
6   0x10999f3ef WebCore::Element::insertedIntoDocument()
7   0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
8   0x10999f3ef WebCore::Element::insertedIntoDocument()
9   0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
10  0x10999f3ef WebCore::Element::insertedIntoDocument()
11  0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
12  0x10999f3ef WebCore::Element::insertedIntoDocument()
13  0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
14  0x10999f3ef WebCore::Element::insertedIntoDocument()
15  0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
16  0x10999f3ef WebCore::Element::insertedIntoDocument()
17  0x1095e963e WebCore::ContainerNode::insertedIntoDocument()
18  0x10999f3ef WebCore::Element::insertedIntoDocument()
19  0x1095e728c _ZN7WebCoreL19notifyChildInsertedEPNS_4NodeE
20  0x1095e6984 WebCore::ContainerNode::appendChild(WTF::PassRefPtr<WebCore::Node>, int&, bool)
21  0x10a34f4f2 WebCore::Node::appendChild(WTF::PassRefPtr<WebCore::Node>, int&, bool)
22  0x10a0265ea WebCore::JSNode::appendChild(JSC::ExecState*)
23  0x10a022499 WebCore::jsNodePrototypeFunctionAppendChild(JSC::ExecState*)
24  0x4059424011f8
25  0x108b31929 JSC::JITCode::execute(JSC::RegisterFile*, JSC::ExecState*, JSC::JSGlobalData*)
26  0x108b2e266 JSC::Interpreter::executeCall(JSC::ExecState*, JSC::JSObject*, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
27  0x108a82ab1 JSC::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
28  0x109dbe303 WebCore::JSMainThreadExecState::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&)
29  0x10a68b203 WebCore::ScheduledAction::executeFunctionInContext(JSC::JSGlobalObject*, JSC::JSValue, WebCore::ScriptExecutionContext*)
30  0x10a68ace9 WebCore::ScheduledAction::execute(WebCore::Document*)
31  0x10a68ab14 WebCore::ScheduledAction::execute(WebCore::ScriptExecutionContext*)

Expected result:
No assert failure.
Comment 1 Eric Seidel (no email) 2012-01-03 13:39:18 PST
This does not reproduce for me in a Debug build, but it may have been ad-related.  We'll need more reports (or a reproduction) to be sure.

*** This bug has been marked as a duplicate of bug 50312 ***