Bug 71027 - [Cairo] Implement ShareableBitmap::paint() when scaleFactor=1
: [Cairo] Implement ShareableBitmap::paint() when scaleFactor=1
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: WebKit2
: 528+ (Nightly build)
: PC Linux
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-27 09:50 PDT by Carlos Garcia Campos
Modified: 2011-10-27 10:27 PDT (History)
0 users

See Also:


Attachments
Patch (1.80 KB, patch)
2011-10-27 10:05 PDT, Carlos Garcia Campos
mrobinson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2011-10-27 09:50:49 PDT
The addition of scaleFactor support in plugins introduced a regression in GTK port because paint() is called with a scaleFactor even when it's 1, and the method is not implemented in Cairo backing store.
Comment 1 Carlos Garcia Campos 2011-10-27 10:05:01 PDT
Created attachment 112696 [details]
Patch
Comment 2 Carlos Garcia Campos 2011-10-27 10:27:32 PDT
Committed r98599: <http://trac.webkit.org/changeset/98599>