Bug 70876 - Implement history.state
: Implement history.state
Status: RESOLVED DUPLICATE of bug 76035
Product: WebKit
Classification: Unclassified
Component: History
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: jochen
: InRadar
Depends on:
  Show dependency treegraph
Reported: 2011-10-25 23:36 PDT by Darin Fisher (:fishd, Google)
Modified: 2012-01-20 15:31 PST (History)
9 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Darin Fisher (:fishd, Google) 2011-10-25 23:36:04 PDT
Implement history.state


It looks like Firefox 4 and Opera 11.50 implement history.state.

It is pretty useful to allow pages to read the current history state directly without just having to wait for a popstate event.
Comment 1 Brady Eidson 2011-10-26 09:36:16 PDT
Comment 2 Adam Barth 2012-01-20 15:31:49 PST
@jochen: There's been some work on this topic in Bug 76035.

*** This bug has been marked as a duplicate of bug 76035 ***