JSEventTarget.cpp has a bunch of unnessary includes
Created attachment 112438 [details] Patch
Comment on attachment 112438 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=112438&action=review > Source/WebCore/webaudio/JavaScriptAudioNode.h:49 > +// FIXME: AudioNode should be introduced at the base of the inheritance hierarchy (i.e., as a base class for AudioNode). I'm not sure this makes sense? You use AudioNode twice?
> I'm not sure this makes sense? You use AudioNode twice? Yeah, I meant EventTarget the first time.
Created attachment 112440 [details] Patch for landing
Comment on attachment 112440 [details] Patch for landing Clearing flags on attachment: 112440 Committed r98427: <http://trac.webkit.org/changeset/98427>
All reviewed patches have been landed. Closing bug.
Adam, FYI, Dominic and I have been talking about making JavaScriptAudioNode *not* be an EventTarget at all. But instead use a Callback instead of EventListener
Even better. BTW, is it too late to rename the interface? Having "JavaScript" in an interface name doesn't make much sense. (Imagine Python bindings for the DOM.)
(In reply to comment #8) > Even better. > > BTW, is it too late to rename the interface? Having "JavaScript" in an interface name doesn't make much sense. (Imagine Python bindings for the DOM.) I agree that the name isn't the best. Unfortunately, JavaScriptAudioNode is one of the most common nodes people are using, so if we do change the name then I want to provide a deprecation path where the old name (as well as the new name) continues to work for a period of time.
Deprecation path seems OK. They talk about how the future is always larger than the past. :) So seems like if we ever want to have other languages in the browser, JavaScript is a bad interface prefix. :)