WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
70572
Refactor OptionsObject.cpp
https://bugs.webkit.org/show_bug.cgi?id=70572
Summary
Refactor OptionsObject.cpp
Kentaro Hara
Reported
2011-10-20 19:14:23 PDT
For example, OptionsObject::getKeyBool() is an alias of OptionsObject::getKeyValue(const String& key, bool& value). We should remove OptionsObject::getKeyXXXX() (XXXX is some specific type) and unify them into OptionsObject::getKeyValue(const String& key, XXXX& value). c.f. Corresponding JSC methods are unified into JSDictionary::convertValue(JSC::ExecState*, JSC::JSValue, XXXX&).
Attachments
Patch
(11.55 KB, patch)
2011-10-20 19:45 PDT
,
Kentaro Hara
no flags
Details
Formatted Diff
Diff
patch for commit
(16.00 KB, patch)
2011-10-26 17:38 PDT
,
Kentaro Hara
no flags
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Kentaro Hara
Comment 1
2011-10-20 19:45:45 PDT
Created
attachment 111890
[details]
Patch
Adam Barth
Comment 2
2011-10-26 09:45:11 PDT
Comment on
attachment 111890
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=111890&action=review
> Source/WebCore/bindings/v8/OptionsObject.h:54 > + bool getKeyValue(const String&, bool&) const; > + bool getKeyValue(const String&, int32_t&) const; > + bool getKeyValue(const String&, double&) const; > + bool getKeyValue(const String&, String&) const; > + bool getKeyValue(const String&, ScriptValue&) const;
Why not just call these functions "get" ?
> Source/WebCore/bindings/v8/OptionsObject.h:61 > + bool getKeyValueWithUndefinedOrNullCheck(const String&, String&) const;
getWithUndefinedOrNullCheck ?
Kentaro Hara
Comment 3
2011-10-26 17:38:14 PDT
Created
attachment 112624
[details]
patch for commit
Kentaro Hara
Comment 4
2011-10-26 17:39:53 PDT
(In reply to
comment #2
)
> (From update of
attachment 111890
[details]
) > View in context:
https://bugs.webkit.org/attachment.cgi?id=111890&action=review
> > > Source/WebCore/bindings/v8/OptionsObject.h:54 > > + bool getKeyValue(const String&, bool&) const; > > + bool getKeyValue(const String&, int32_t&) const; > > + bool getKeyValue(const String&, double&) const; > > + bool getKeyValue(const String&, String&) const; > > + bool getKeyValue(const String&, ScriptValue&) const; > > Why not just call these functions "get" ? > > > Source/WebCore/bindings/v8/OptionsObject.h:61 > > + bool getKeyValueWithUndefinedOrNullCheck(const String&, String&) const; > > getWithUndefinedOrNullCheck ?
Done and committed. Thanks!!
WebKit Review Bot
Comment 5
2011-10-27 07:52:07 PDT
Comment on
attachment 112624
[details]
patch for commit Clearing flags on attachment: 112624 Committed
r98572
: <
http://trac.webkit.org/changeset/98572
>
Eric Seidel (no email)
Comment 6
2011-12-21 14:24:59 PST
Attachment 111890
[details]
was posted by a committer and has review+, assigning to Kentaro Hara for commit.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug