Bug 70081 - REGRESSION (Safari 5.1 - 5.1.1): CSS nesw-resize cursor shows up as a sw-resize cursor
Summary: REGRESSION (Safari 5.1 - 5.1.1): CSS nesw-resize cursor shows up as a sw-resi...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac (Intel) OS X 10.7
: P1 Normal
Assignee: Nobody
URL: data:text/html,<div style="cursor:nes...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2011-10-13 18:21 PDT by Kevin Haggerty
Modified: 2011-10-14 12:17 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Haggerty 2011-10-13 18:21:50 PDT
Adding this CSS to an element:

.resize {
  cursor: nesw-resize;
}

does not work as expected.  Cursor actually shows up as a sw-resize cursor.  the nwse-resize cursor is unaffected, and shows up as expected.
Comment 1 Kevin Haggerty 2011-10-14 04:14:30 PDT
Tested this in Safari 5.1 (MacOS 10.7) and nesw-resize works as expected.  This bug only shows up in the latest webkit nightly.
Comment 2 Alexey Proskuryakov 2011-10-14 10:56:28 PDT
This is due to a typo in WebKitSystemInterface changes for <http://trac.webkit.org/changeset/90087>. 

Safari 5.1.1 on Lion is affected.
Comment 3 Darin Adler 2011-10-14 11:25:46 PDT
Oops.
Comment 4 Darin Adler 2011-10-14 11:26:32 PDT
I could have sworn I tested those all!
Comment 5 mitz 2011-10-14 11:32:05 PDT
<rdar://problem/10288112>
Comment 6 mitz 2011-10-14 12:17:52 PDT
Fixed in <http://trac.webkit.org/r97490>.