Bug 69863 - DFG JIT 32_64 - Switch to cdecl calling convention.
Summary: DFG JIT 32_64 - Switch to cdecl calling convention.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-11 13:39 PDT by Gavin Barraclough
Modified: 2011-10-11 15:50 PDT (History)
1 user (show)

See Also:


Attachments
The patch (35.78 KB, patch)
2011-10-11 13:54 PDT, Gavin Barraclough
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2011-10-11 13:39:38 PDT
This makes it easier to keep the stack correctly aligned, which is reuired on OS X.
Comment 1 Gavin Barraclough 2011-10-11 13:54:04 PDT
Created attachment 110570 [details]
The patch
Comment 2 WebKit Review Bot 2011-10-11 13:56:41 PDT
Attachment 110570 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/dfg/DFGOperations.h:87:  DFG_OPERATION is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/dfg/DFGJITCodeGenerator.h:1252:  Extra space before ( in function call  [whitespace/parens] [4]
Total errors found: 2 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Oliver Hunt 2011-10-11 14:20:52 PDT
Comment on attachment 110570 [details]
The patch

View in context: https://bugs.webkit.org/attachment.cgi?id=110570&action=review

r=me, fix the spelling error and the sizeof<SPACE!!!!>( style error

> Source/JavaScriptCore/ChangeLog:8
> +        This makes it easier to keep the stack correctly aligned, which is reuired on OS X.

required.

r-!!!!!111!!!1!!!111!1

> Source/JavaScriptCore/dfg/DFGJITCodeGenerator.h:1060
> +        m_jit.move(Imm32(numConstants), GPRInfo::argumentGPR2);
> +        m_jit.move(Imm32(startConstant), GPRInfo::argumentGPR1);

well caught sir!

>> Source/JavaScriptCore/dfg/DFGJITCodeGenerator.h:1252
>> +        m_jit.storeDouble(value, JITCompiler::Address(JITCompiler::stackPointerRegister, m_callArgumentIndex * sizeof (void*)));
> 
> Extra space before ( in function call  [whitespace/parens] [4]

This is a real style bug in the sizeof
Comment 4 Gavin Barraclough 2011-10-11 15:50:59 PDT
Fixed in r97189