It's been removed in GStreamer 0.11 and can be replaced with G_DEFINE_TYPE_WITH_CODE.
Created attachment 110150 [details] proposed patch
Attachment 110150 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1 Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:136: More than one command on the same line [whitespace/newline] [4] Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:138: webkit_web_src_class_init is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:211: webkit_web_src_init is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 3 in 2 files If any of these errors are false positives, please file a bug against check-webkit-style.
(In reply to comment #2) > Attachment 110150 [details] did not pass style-queue: > > Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1 > > Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:136: More than one command on the same line [whitespace/newline] [4] > Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:138: webkit_web_src_class_init is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] > Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:211: webkit_web_src_init is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] > Total errors found: 3 in 2 files > > This is how G_DEFINE_TYPE works, I can't rename those functions I'm afraid.
Comment on attachment 110150 [details] proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=110150&action=review >> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:136 >> + GST_DEBUG_CATEGORY_INIT(webkit_web_src_debug, "webkitwebsrc", 0, "websrc element");); > > More than one command on the same line [whitespace/newline] [4] You can split this out into two macros if you wish: // We split this out into another macro to avoid a check-webkit-style error. #define WEBKIT_WEB_SRC_CATEGORY_INIT GST_DEBUG_CATEGORY_INIT(webkit_web_src_debug, "webkitwebsrc", 0, "websrc element"); G_DEFINE_TYPE_WITH_CODE(WebKitWebSrc, webkit_web_src, GST_TYPE_BIN, G_IMPLEMENT_INTERFACE(GST_TYPE_URI_HANDLER, webKitWebSrcUriHandlerInit); WEBKIT_WEB_SRC_CATEGORY_INIT); >> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:138 >> +static void webkit_web_src_class_init(WebKitWebSrcClass* klass) > > webkit_web_src_class_init is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] I think it would be good to do something similar to here: https://bugs.webkit.org/show_bug.cgi?id=69481
Comment on attachment 110150 [details] proposed patch Looks sane.
Committed r96942: <http://trac.webkit.org/changeset/96942>