REOPENED Bug 69446
Use std::reverse_iterator for ListHashSet reverse iterators
https://bugs.webkit.org/show_bug.cgi?id=69446
Summary Use std::reverse_iterator for ListHashSet reverse iterators
Anders Carlsson
Reported 2011-10-05 11:23:09 PDT
Use std::reverse_iterator for ListHashSet reverse iterators
Attachments
Patch (10.04 KB, patch)
2011-10-05 11:24 PDT, Anders Carlsson
darin: review+
dbates: commit-queue-
Anders Carlsson
Comment 1 2011-10-05 11:24:27 PDT
Darin Adler
Comment 2 2011-10-05 11:26:01 PDT
Comment on attachment 109827 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=109827&action=review Did you test this? Does it work? > Source/JavaScriptCore/ChangeLog:13 > + (WTF::::rbegin): > + (WTF::::rend): You should remove these garbled lines from the change log.
WebKit Review Bot
Comment 3 2011-10-05 11:27:04 PDT
Attachment 109827 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1 Source/JavaScriptCore/wtf/ListHashSet.h:80: reverse_iterator is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:81: const_reverse_iterator is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:274: iterator_category is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:275: value_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:278: difference_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:328: iterator_category is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:329: value_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/JavaScriptCore/wtf/ListHashSet.h:332: difference_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 8 in 2 files If any of these errors are false positives, please file a bug against check-webkit-style.
Anders Carlsson
Comment 4 2011-10-05 11:28:55 PDT
Darin Adler
Comment 6 2011-10-05 12:50:49 PDT
Apparently on older toolsets, <iterator> is not compatible with -fno-exceptions.
Darin Adler
Comment 7 2011-10-05 12:52:14 PDT
Maybe not practical if we support those old Mac toolsets?
Anders Carlsson
Comment 8 2011-10-05 13:30:10 PDT
(In reply to comment #7) > Maybe not practical if we support those old Mac toolsets? It seems to me like if we include something that ends up including exception_defines.h we should be fine - it contains macros that define away try/catch.
Daniel Bates
Comment 9 2011-10-16 04:17:10 PDT
Note You need to log in before you can comment on or make changes to this bug.