Bug 6942 - Assertion failure in HTMLSelectElementImpl::selectedIndex (m_multiple)
Summary: Assertion failure in HTMLSelectElementImpl::selectedIndex (m_multiple)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://bugzilla.opendarwin.org/enter_...
Keywords:
: 6974 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-30 14:13 PST by mitz
Modified: 2006-01-31 11:00 PST (History)
2 users (show)

See Also:


Attachments
Remove the assert (3.09 KB, patch)
2006-01-30 14:36 PST, mitz
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-01-30 14:13:02 PST
The assert at the end of HTMLSelectElementImpl::selectedIndex fails when no item is selected. It went unnoticed before because it was a Q_ASSERT, but in r12471 it was changed to an ASSERT.
Anyway, it is bogus since -1 is the correct value to return when no option is selected.
Comment 1 mitz 2006-01-30 14:36:03 PST
Created attachment 6119 [details]
Remove the assert

Not sure the test is necessary
Comment 2 Adele Peterson 2006-01-30 14:36:54 PST
Comment on attachment 6119 [details]
Remove the assert

r=me
Comment 3 Darin Adler 2006-01-30 23:07:04 PST
Oops, yes, I was wondering which of the Q_ASSERT that I changed to ASSERT were bogus. Sorry, my mistake.
Comment 4 John Sullivan 2006-01-31 11:00:33 PST
*** Bug 6974 has been marked as a duplicate of this bug. ***