Bug 69413 - REGRESSION(r96347): Build is broken with MSVC compiler if !PLATFORM(WINDOWS)
Summary: REGRESSION(r96347): Build is broken with MSVC compiler if !PLATFORM(WINDOWS)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All Windows XP
: P1 Critical
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks: 69058
  Show dependency treegraph
 
Reported: 2011-10-05 05:06 PDT by Csaba Osztrogonác
Modified: 2011-10-06 04:56 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.35 KB, patch)
2011-10-05 06:30 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (1.38 KB, patch)
2011-10-05 07:35 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-10-05 05:06:22 PDT
http://trac.webkit.org/changeset/96347/trunk/Source/JavaScriptCore/assembler/MacroAssemblerCodeRef.h broke
QtWebKit build on Windows with MSVC2008 Express with the following build error:

MacroAssemblerCodeRef.h(112) : error C2059: syntax error : 'function-style cast'
...
Comment 1 Csaba Osztrogonác 2011-10-05 05:32:57 PDT
I got it, defining STDCALL is incorrenct if !PLATFORM(WINDOWS)  && COMPILER(MSVC).

Fix is coming soon.
Comment 2 Csaba Osztrogonác 2011-10-05 06:30:03 PDT
Created attachment 109782 [details]
Patch
Comment 3 Csaba Osztrogonác 2011-10-05 06:32:17 PDT
(In reply to comment #2)
> Created an attachment (id=109782) [details]
> Patch

The root of the problem was that PLATFORM(WINDOWS) == Apple Windows port,
but if you build eg QtWebKit on Windows with MSVC, PLATFORM(WINDOWS) == false,
OS(WIN) == true, COMPILER(MSVC) == true.
Comment 4 Gyuyoung Kim 2011-10-05 06:58:43 PDT
Comment on attachment 109782 [details]
Patch

Attachment 109782 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/9954397
Comment 5 Csaba Osztrogonác 2011-10-05 07:01:21 PDT
Comment on attachment 109782 [details]
Patch

ooops
Comment 6 Csaba Osztrogonác 2011-10-05 07:35:55 PDT
Created attachment 109790 [details]
Patch
Comment 7 WebKit Review Bot 2011-10-06 04:56:51 PDT
Comment on attachment 109790 [details]
Patch

Clearing flags on attachment: 109790

Committed r96802: <http://trac.webkit.org/changeset/96802>
Comment 8 WebKit Review Bot 2011-10-06 04:56:55 PDT
All reviewed patches have been landed.  Closing bug.