Bug 69225 - Webkit-GTK should provide information about missing plugins
Summary: Webkit-GTK should provide information about missing plugins
Status: RESOLVED DUPLICATE of bug 34085
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-02 10:11 PDT by ManDay
Modified: 2011-10-02 10:42 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ManDay 2011-10-02 10:11:36 PDT
http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-base-libs/html/gst-plugins-base-libs-gstpbutilsmissingplugins.html

It's unbearable that the user is put through a lengthy trial-and-error process in order to figure out which plugin he is missing for a particular video or audio. Webkit-GTK has to provide such information to the user, at the very least which codec (a/v) is attempted to be played and failed. Optionally, which plugin is require to play that specific codec. Optionall, Webkit-GTK should interface with the respective gstreamer functions to install that codec for the user by means of the correct package management system, with which gstreamer will interface.

For a start, such information could be written to stdout. Eventually, it should be correctly provided through a complete context menu and dialog which in turn is acessible by right-clicking the gstreamer frame.
Comment 1 ManDay 2011-10-02 10:42:30 PDT

*** This bug has been marked as a duplicate of bug 34085 ***