Bug 6916 - REGRESSION: URLs with named anchors in a page don't jump to proper location in document
: REGRESSION: URLs with named anchors in a page don't jump to proper location i...
Status: VERIFIED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 420+
: Macintosh Mac OS X 10.4
: P1 Major
Assigned To: Vicki Murley
http://www.nola.com/newslogs/tpupdate...
: Regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 11:46 PST by Gibbons Burke
Modified: 2006-06-11 05:08 PDT (History)
3 users (show)

See Also:


Attachments
Reduced test case (2.73 KB, text/html)
2006-01-29 20:45 PST, David Kilzer (:ddkilzer)
no flags Details
Patch committed to svn (49.63 KB, patch)
2006-01-31 19:18 PST, David Kilzer (:ddkilzer)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gibbons Burke 2006-01-29 11:46:48 PST
The URL included above is a "Permalink" pointer to a named anchor within the page of a news blog. Instead of scrolling directly to the named anchor tag, the latest version of Safari scrolls to the end of the page.

The URL works as expected (correctly) in latest production versions of Safari, Firefox and OmniWeb. The bug has been present for some time in the nightly build versions.
Comment 1 David Kilzer (:ddkilzer) 2006-01-29 20:02:06 PST
Confirmed bug.
Comment 2 David Kilzer (:ddkilzer) 2006-01-29 20:45:47 PST
Created attachment 6095 [details]
Reduced test case

Reduced test case attached, although a smaller one may be possible.

The <font> tag in front of the <a name=""> tag is significant.
Comment 3 Vicki Murley 2006-01-30 11:33:55 PST
<rdar://problem/4426668>
Comment 4 Vicki Murley 2006-01-30 16:39:03 PST
Fixed.
Comment 5 David Kilzer (:ddkilzer) 2006-01-30 16:48:49 PST
Is there a patch available for this?  I didn't see anything checked into Subversion (yet), either.  How can it be marked RESOLVED/FIXED?
Comment 6 David Kilzer (:ddkilzer) 2006-01-30 21:07:30 PST
Reopening since there is no patch and nothing was committed to Subversion to fix this bug.
Comment 7 Vicki Murley 2006-01-31 10:41:06 PST
How strange. . . I committed this on my work machine yesterday, but I guess something went wrong b/c this change is not in TOT.  Maybe there was a conflict in one of the files and the commit didn't go through.  Sorry!
Comment 8 Vicki Murley 2006-01-31 13:50:10 PST
I see now why my previous commit failed:

"The following files contain tab characters:

        trunk/WebCore/ChangeLog"

I just recommitted. 
Comment 9 David Kilzer (:ddkilzer) 2006-01-31 19:18:27 PST
Created attachment 6171 [details]
Patch committed to svn
Comment 10 David Kilzer (:ddkilzer) 2006-01-31 20:17:26 PST
Verified fixed as of r12510.
Comment 11 Eric Seidel 2006-01-31 21:20:59 PST
Removing Regression keyword from bugs already fixed.
Comment 12 David Kilzer (:ddkilzer) 2006-06-11 05:08:18 PDT
(In reply to comment #11)
> Removing Regression keyword from bugs already fixed.

Regression keyword re-added.