Bug 69078 - [Chromium] some Layout Tests in editing/ is failing
Summary: [Chromium] some Layout Tests in editing/ is failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-29 03:25 PDT by Shinichiro Hamaji
Modified: 2011-10-27 23:08 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shinichiro Hamaji 2011-09-29 03:25:21 PDT
The following layout test is failing on Mac CG

editing/deleting/table-cells.html
editing/execCommand/create-list-with-hr.html
editing/execCommand/find-after-replace.html
editing/execCommand/paste-1.html
editing/execCommand/paste-2.html
editing/inserting/4278698.html
editing/inserting/paragraph-separator-in-table-2.html
editing/pasteboard/3976872.html
editing/pasteboard/4076267-2.html
editing/pasteboard/4076267-3.html
editing/pasteboard/4076267.html
editing/pasteboard/undoable-fragment-removes.html
editing/selection/select-all-iframe.html
editing/undo/4063751.html
editing/unsupported-content/table-type-after.html
editing/unsupported-content/table-type-before.html

Probable cause:

Failed to rebaseline?
Comment 1 Shinichiro Hamaji 2011-09-29 03:29:24 PDT
Committed r96315: <http://trac.webkit.org/changeset/96315>
Comment 2 Ryosuke Niwa 2011-09-29 08:44:59 PDT
No(In reply to comment #0)
> The following layout test is failing on Mac CG
> 
> editing/deleting/table-cells.html
> editing/execCommand/create-list-with-hr.html
> editing/execCommand/find-after-replace.html
> editing/execCommand/paste-1.html
> editing/execCommand/paste-2.html
> editing/inserting/4278698.html
> editing/inserting/paragraph-separator-in-table-2.html
> editing/pasteboard/3976872.html
> editing/pasteboard/4076267-2.html
> editing/pasteboard/4076267-3.html
> editing/pasteboard/4076267.html
> editing/pasteboard/undoable-fragment-removes.html
> editing/selection/select-all-iframe.html
> editing/undo/4063751.html
> editing/unsupported-content/table-type-after.html
> editing/unsupported-content/table-type-before.html
> 
> Probable cause:
> 
> Failed to rebaseline?

No, if you look at results, text isn't rendered properly there.
Comment 3 Ryosuke Niwa 2011-09-29 08:45:12 PDT
This is probably a skia bug.
Comment 4 Ryosuke Niwa 2011-09-29 09:07:48 PDT
http://crbug.com/98557
Comment 5 Ryosuke Niwa 2011-10-27 23:08:24 PDT
Rebaselined.