Bug 69056 - Check behavior of tabindex attribute with a large number
Summary: Check behavior of tabindex attribute with a large number
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Kent Tamura
URL:
Keywords:
Depends on: 68981
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-28 18:43 PDT by Kent Tamura
Modified: 2011-10-20 23:52 PDT (History)
1 user (show)

See Also:


Attachments
Patch (5.32 KB, patch)
2011-10-02 23:48 PDT, Kent Tamura
dbates: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2011-09-28 18:43:44 PDT
Bug 68981 exposed that we had never checked overflow of the attribute value.
Comment 1 Kent Tamura 2011-10-02 23:48:35 PDT
Created attachment 109444 [details]
Patch
Comment 2 Daniel Bates 2011-10-16 05:33:34 PDT
Comment on attachment 109444 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=109444&action=review

> LayoutTests/fast/dom/tabindex-defaults.html:11
> +<div id="console"></div>
> +
> +<div id=container>

Nit: This patch is inconsistent in its use of quotes around attribute values. I suggest picking one style for consistency. For example, on line 9 you put quotes around the attribute value of id, but on line 10 you don't. Similar inconsistencies can be seen in the rest of the HTML markup in this file.

> LayoutTests/fast/dom/tabindex-defaults.html:31
> +var anchor = document.getElementById('a1');
> +var button = document.getElementById('b1');
> +var input = document.getElementById('i1');
> +var select = document.getElementById('s1');
> +var textarea = document.getElementById('t1');
> +var editableDiv = document.getElementById('e1');
> +var normalDiv = document.getElementById('u1');

This is fine as-is. For your consideration, I suggest renaming the ids of the elements to match these variable names. That is, rename "a1" to "anchor", rename "b1" to "button", and so forth.
Comment 3 Kent Tamura 2011-10-20 23:51:32 PDT
Committed r98075: <http://trac.webkit.org/changeset/98075>
Comment 4 Kent Tamura 2011-10-20 23:52:28 PDT
(In reply to comment #2)
> (From update of attachment 109444 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=109444&action=review

Thank you for your comments.  I update the patch for your comments, and landed it.