Bug 69046 - DFG JIT Operations on 32_64 should use stdcall calling convention.
Summary: DFG JIT Operations on 32_64 should use stdcall calling convention.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-28 17:57 PDT by Gavin Barraclough
Modified: 2011-09-28 19:52 PDT (History)
2 users (show)

See Also:


Attachments
Fix (50.53 KB, patch)
2011-09-28 18:03 PDT, Gavin Barraclough
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2011-09-28 17:57:34 PDT
All calls out are expecting stdcall conventions, but the default on OS X are cdecl.
Comment 1 Gavin Barraclough 2011-09-28 18:03:00 PDT
Created attachment 109106 [details]
Fix
Comment 2 WebKit Review Bot 2011-09-28 18:05:56 PDT
Attachment 109106 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Last 3072 characters of output:
iptCore/dfg/DFGOperations.h:88:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:278:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:278:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:301:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:301:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:321:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:321:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:341:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:341:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:405:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:405:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:428:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:428:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:451:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:451:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:474:  The parameter name "exec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:474:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:658:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/dfg/DFGOperations.cpp:671:  The parameter name "returnAddress" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 33 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2011-09-28 18:13:37 PDT
Comment on attachment 109106 [details]
Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=109106&action=review

> Source/JavaScriptCore/assembler/MacroAssemblerCodeRef.h:59
> +// Defined on X86 platforms if stdcall is not the standard!
> +#define STDCALL_NOT_STANDARD __attribute__ ((stdcall))

How about we replace the second standard with default.  This should probably be in Compiler.h.

> Source/JavaScriptCore/dfg/DFGJITCodeGenerator.h:1319
> +#if !PLATFORM(MAC)

Please give this #define a more clear explanation.
Comment 4 Gavin Barraclough 2011-09-28 18:35:11 PDT
Fixed in r96286.
Comment 7 Ryosuke Niwa 2011-09-28 19:52:21 PDT
Build fix attempted in http://trac.webkit.org/changeset/96288.

But now Leopard is broken although this failure seems much more reasonable:
http://build.webkit.org/builders/Leopard%20Intel%20Debug%20%28Build%29/builds/39971/steps/compile-webkit/logs/stdio