Bug 68926 - REGRESSION: Frequent crashes in WebCore::Frame::contentRenderer()
Summary: REGRESSION: Frequent crashes in WebCore::Frame::contentRenderer()
Status: RESOLVED DUPLICATE of bug 68893
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P1 Major
Assignee: Nobody
URL:
Keywords: Regression
: 68947 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-27 12:42 PDT by Kevin M. Dean
Modified: 2011-09-27 18:53 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2011-09-27 12:42:22 PDT
Since upgrading to r96101, my tabs keep on unexpectedly reloading due to Web Process crashes. 12 times so far.

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.WebCore             	0x0000000109aae6e6 WebCore::Frame::contentRenderer() const + 4
1   com.apple.WebCore             	0x0000000109acf0e0 non-virtual thunk to WebCore::FrameView::layerForVerticalScrollbar() const + 16
2   com.apple.WebCore             	0x000000010a0c5540 WebCore::ScrollableArea::invalidateScrollbar(WebCore::Scrollbar*, WebCore::IntRect const&) + 104
3   com.apple.WebCore             	0x000000010a0d0461 WebCore::ScrollView::setHasVerticalScrollbar(bool) + 343
4   com.apple.WebCore             	0x0000000109ad3346 WebCore::FrameView::~FrameView() + 232
5   com.apple.WebCore             	0x000000010987cc7c WebCore::CachedFrame::clear() + 174
6   com.apple.WebCore             	0x000000010987e765 WebCore::CachedPage::destroy() + 27
7   com.apple.WebCore             	0x0000000109f60df8 WebCore::PageCache::releaseAutoreleasedPagesNow() + 138
8   com.apple.WebCore             	0x000000010a1e3e5e WebCore::ThreadTimers::sharedTimerFiredInternal() + 120
9   com.apple.WebCore             	0x000000010a0ea357 _ZN7WebCoreL10timerFiredEP16__CFRunLoopTimerPv + 55
10  com.apple.CoreFoundation      	0x00007fff89ca4694 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
11  com.apple.CoreFoundation      	0x00007fff89ca41e6 __CFRunLoopDoTimer + 534
12  com.apple.CoreFoundation      	0x00007fff89c84ba1 __CFRunLoopRun + 1617
13  com.apple.CoreFoundation      	0x00007fff89c84216 CFRunLoopRunSpecific + 230
14  com.apple.HIToolbox           	0x00007fff91dfb4ff RunCurrentEventLoopInMode + 277
15  com.apple.HIToolbox           	0x00007fff91e02c21 ReceiveNextEventCommon + 355
16  com.apple.HIToolbox           	0x00007fff91e02aae BlockUntilNextEventMatchingListInMode + 62
17  com.apple.AppKit              	0x00007fff92b1b191 _DPSNextEvent + 659
18  com.apple.AppKit              	0x00007fff92b1aa95 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
19  com.apple.AppKit              	0x00007fff92b173d6 -[NSApplication run] + 463
20  com.apple.WebKit2             	0x000000010921c555 RunLoop::run() + 125
21  com.apple.WebKit2             	0x0000000109262b81 WebKit::WebProcessMain(WebKit::CommandLine const&) + 587
22  com.apple.WebKit2             	0x00000001092371b0 WebKitMain + 268
23  com.apple.WebProcess          	0x000000010908be56 main + 234
24  com.apple.WebProcess          	0x000000010908bd64 start + 52
Comment 1 Alexey Proskuryakov 2011-09-27 17:18:37 PDT
*** Bug 68947 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Proskuryakov 2011-09-27 17:19:47 PDT
Per bug 68947, this frequently happens on macupdate.com, in particular.
Comment 3 Simon Fraser (smfr) 2011-09-27 17:34:22 PDT

*** This bug has been marked as a duplicate of bug 68893 ***