Instead of function based.
Created attachment 108790 [details]
Comment on attachment 108790 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=108790&action=review
Thanks. I've had to learn this the hard way. Basically it becomes impossible to test static module funtions. Adding them into a class makes it super easy to have the class hold an Executive/FileSystem/User or other mockable object if needed.
> _INVALID_DEFINITION_NAME_REGEX = r'\|'
I bet you want to make these class members now too.
> + watch_list_parser = WatchListParser()
You could have a setUp which allocates self.parser = WatchListParser() if you prefer.
Changed as suggested.
Committed as http://trac.webkit.org/changeset/96115.