We need at least network errors for the loader client
Created attachment 108120 [details] Patch
Created attachment 108135 [details] Updated patch I forgot to add new headers to the main header in previous patch.
Created attachment 108993 [details] Updated patch Patch updated to current git master.
Attachment 108993 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1 Source/WebKit2/UIProcess/API/gtk/WebKitError.cpp:26: webkit_network_error_quark is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Source/WebKit2/UIProcess/API/gtk/WebKitError.h:39: Extra space before ( in function call [whitespace/parens] [4] Total errors found: 2 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 108993 [details] Updated patch View in context: https://bugs.webkit.org/attachment.cgi?id=108993&action=review > Source/WebKit2/GNUmakefile.am:1019 > + --fprod "\n/* enumerations from \"@filename@\" */" \ Please use: Enumerations from \"@filename@\." > Source/WebKit2/UIProcess/API/gtk/WebKitError.cpp:2 > + * Copyright (C) 2008 Luca Bruno <lethalman88@gmail.com> This should probably be our copyright. > Source/WebKit2/UIProcess/API/gtk/WebKitError.cpp:29 > +GQuark webkit_network_error_quark(void) > +{ > + return g_quark_from_static_string(WebCore::errorDomainNetwork); > +} Please fix the style errors here. No need to have a "void" for an empty argument list. > Source/WebKit2/UIProcess/API/gtk/WebKitError.h:2 > + * Copyright (C) 2008 Luca Bruno <lethalman88@gmail.com> Ditto. > Source/WebKit2/UIProcess/API/gtk/WebKitError.h:28 > +#define WEBKIT_NETWORK_ERROR webkit_network_error_quark () Is this a work-around for some issue or is it standard practice. If it's just a work-around I think we should just use webkit_network_error_quark everywhere. > Source/WebKit2/UIProcess/API/gtk/WebKitError.h:35 > + WEBKIT_NETWORK_ERROR_FAILED = 399, > + WEBKIT_NETWORK_ERROR_TRANSPORT = 300, > + WEBKIT_NETWORK_ERROR_UNKNOWN_PROTOCOL = 301, > + WEBKIT_NETWORK_ERROR_CANCELLED = 302, > + WEBKIT_NETWORK_ERROR_FILE_DOES_NOT_EXIST = 303 Please don't unalign these.
(In reply to comment #5) > (From update of attachment 108993 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=108993&action=review > > > Source/WebKit2/GNUmakefile.am:1019 > > + --fprod "\n/* enumerations from \"@filename@\" */" \ > > Please use: Enumerations from \"@filename@\." Ok. > > > Source/WebKit2/UIProcess/API/gtk/WebKitError.h:28 > > +#define WEBKIT_NETWORK_ERROR webkit_network_error_quark () > > Is this a work-around for some issue or is it standard practice. If it's just a work-around I think we should just use webkit_network_error_quark everywhere. This is standard practice. > > Source/WebKit2/UIProcess/API/gtk/WebKitError.h:35 > > + WEBKIT_NETWORK_ERROR_FAILED = 399, > > + WEBKIT_NETWORK_ERROR_TRANSPORT = 300, > > + WEBKIT_NETWORK_ERROR_UNKNOWN_PROTOCOL = 301, > > + WEBKIT_NETWORK_ERROR_CANCELLED = 302, > > + WEBKIT_NETWORK_ERROR_FILE_DOES_NOT_EXIST = 303 > > Please don't unalign these. Ok.
Committed r96225: <http://trac.webkit.org/changeset/96225>