Bug 68398 - Need to specify a django version, instead of using default
Summary: Need to specify a django version, instead of using default
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tom Zakrajsek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-19 15:17 PDT by Tom Zakrajsek
Modified: 2011-09-20 17:33 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.19 KB, patch)
2011-09-19 15:22 PDT, Tom Zakrajsek
no flags Details | Formatted Diff | Diff
Patch (1.74 KB, patch)
2011-09-19 16:18 PDT, Tom Zakrajsek
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Zakrajsek 2011-09-19 15:17:18 PDT
When running test-webkit-scripts, we get the following warning:

WARNING  You are using the default Django version (0.96). The default Django version will change in an App Engine release in the near future. Please call use_library() to explicitly select a Django version. For more information see http://code.google.com/appengine/docs/python/tools/libraries.html#Django.

I tracked this to QueueStatusServer/handlers/queuestatus.py.  We need to explicitly use a library version.  1.2 is suggested on at code.google.com.  I re-tested test-webkit-scripts using 1.2 explicitly and all seems well, so I'm specifying it.  It seems like there are other scripts not specifying this explicitly, but I'm not seeing the warning anywhere else yet.  I'm going to audit the other scripts using django and/or appengine and follow up.
Comment 1 Tom Zakrajsek 2011-09-19 15:22:51 PDT
Created attachment 107927 [details]
Patch
Comment 2 Adam Barth 2011-09-19 15:27:47 PDT
Looks reasonably, but Eric should review this patch.
Comment 3 Eric Seidel (no email) 2011-09-19 15:45:26 PDT
Comment on attachment 107927 [details]
Patch

We already specify one, just in main.py  The problem is that when we are unittesting things we load the __init__.py instead of main.py like appengine does.  We shoul dadd this to __init__.py intead (since it's only really for unittesting), and add a comment that it needs to stay in sync with the one in main.py.
Comment 4 Tom Zakrajsek 2011-09-19 16:18:08 PDT
Created attachment 107939 [details]
Patch
Comment 5 Eric Seidel (no email) 2011-09-19 16:43:46 PDT
Comment on attachment 107939 [details]
Patch

I guess I wasn't aware that 1.2 was even available. :)

I assume you ran the server locally and things didn't barf?
Comment 6 Tom Zakrajsek 2011-09-19 21:48:43 PDT
Comment on attachment 107939 [details]
Patch

cq- since i want to do some additional testing recommended by Eric.
Comment 7 WebKit Review Bot 2011-09-20 17:33:46 PDT
Comment on attachment 107939 [details]
Patch

Clearing flags on attachment: 107939

Committed r95587: <http://trac.webkit.org/changeset/95587>
Comment 8 WebKit Review Bot 2011-09-20 17:33:51 PDT
All reviewed patches have been landed.  Closing bug.