Bug 68391 - check-webkit-style generates bogus warning for StructuredExceptionHandlerSupressor.h
Summary: check-webkit-style generates bogus warning for StructuredExceptionHandlerSupr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: David Levin
URL:
Keywords:
: 68400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-19 14:37 PDT by Chris Marrin
Modified: 2011-09-19 17:41 PDT (History)
2 users (show)

See Also:


Attachments
Patch (2.29 KB, patch)
2011-09-19 15:23 PDT, David Levin
darin: review+
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Marrin 2011-09-19 14:37:00 PDT
Style checking generates:

    Source/WebCore/platform/win/StructuredExceptionHandlerSupressor.h:52:  Extra space before [  [whitespace/braces] [5]

for this line:

    __asm mov [registration], eax

Seems like it doesn't understand Windows assembly well enough.
Comment 1 David Levin 2011-09-19 15:21:33 PDT
*** Bug 68400 has been marked as a duplicate of this bug. ***
Comment 2 David Levin 2011-09-19 15:23:28 PDT
Created attachment 107928 [details]
Patch
Comment 3 WebKit Review Bot 2011-09-19 17:06:47 PDT
Comment on attachment 107928 [details]
Patch

Rejecting attachment 107928 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 1

Last 500 characters of output:
9120b8ae0fc3dfd55045dd4b0a6061b6b9f6c511
r95496 = 6c67a85488c37041218b7b672434107e57743c3b
Done rebuilding .git/svn/refs/remotes/origin/master/.rev_map.268f45cc-cd09-0410-ab3c-d52691b4dbfc
First, rewinding head to replay your work on top of it...
Fast-forwarded master to refs/remotes/origin/master.
Updating chromium port dependencies using gclient...

________ running '/usr/bin/python gyp_webkit' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'
Updating webkit projects from gyp files...

Full output: http://queues.webkit.org/results/9772042
Comment 4 David Levin 2011-09-19 17:08:21 PDT
Whoops. I got too used to gardening and deleted the Reviewed by line. :(

Will commit by hand.
Comment 5 David Levin 2011-09-19 17:41:13 PDT
Committed as http://trac.webkit.org/changeset/95499