http://tinyurl.com/3h8ejbj <div style="position:relative"> <div style="-webkit-writing-mode:vertical-rl;background-color:green;width:400px;height:100px;"> <div id=foo style="background-color:yellow">foo</div> </div> </div> <div style="position:relative"> <div style="-webkit-writing-mode:horizontal-bt;background-color:red;width:400px;height:100px;"> <div id=bar style="background-color:orange">bar</div> </div> </div> I believe foo should have offsetLeft of something like 380, instead of 0 and bar should have offsetTop of something like 80 instead of 0.
Created attachment 108888 [details] Patch
Comment on attachment 108888 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=108888&action=review r=me, but you can rename xFlippedForWritingMode and yFlippedForWritingMode to left() and top(). If you want to go further we could rename locationIncludingFlipping() to topLeftLocation() and locationOffsetIncludingFlipping() to topLeftLocationOffset(). I'd add copious warnings in the header too that these represent your location relative to your container as a physical offset, and that this is rarely what you want in layout() methods. > Source/WebCore/rendering/RenderBox.h:53 > + LayoutUnit yFlippedForWritingMode() const { return locationIncludingFlipping().y(); } > + LayoutUnit xFlippedForWritingMode() const { return locationIncludingFlipping().x(); } Rename these to left() and top().
Committed r96152: <http://trac.webkit.org/changeset/96152>