Bug 6811 - REGRESSION: Can't tab from old text field (like password fields) to new text field
: REGRESSION: Can't tab from old text field (like password fields) to new text ...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Forms
: 420+
: Macintosh Mac OS X 10.4
: P1 Normal
Assigned To: Maciej Stachowiak
: InRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 18:30 PST by Adele Peterson
Modified: 2006-04-03 08:44 PDT (History)
1 user (show)

See Also:


Attachments
test case (138 bytes, text/html)
2006-01-25 18:32 PST, Adele Peterson
no flags Details
the fix is not so bad after all (10.61 KB, patch)
2006-04-02 23:36 PDT, Maciej Stachowiak
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-01-25 18:30:48 PST
I'm not sure this matters that much, since the old text field code will soon go away.  Anyway, this is probably a simple fix.
Comment 1 Adele Peterson 2006-01-25 18:32:40 PST
Created attachment 5967 [details]
test case

test case added.  Can't tab from the old field to the new field, but you can tab from the new to the old.
Comment 2 Adele Peterson 2006-03-01 16:57:20 PST
<rdar://problem/4463760> Can't tab from old text field to new text field (6811)
Comment 3 Adele Peterson 2006-03-29 17:49:06 PST
Bumping to P1 since this causes a text field regression
Comment 4 Maciej Stachowiak 2006-04-02 23:11:05 PDT
*** Bug 8122 has been marked as a duplicate of this bug. ***
Comment 5 Maciej Stachowiak 2006-04-02 23:25:35 PDT
These are all text field regressions so they should all be P1.
Comment 6 Maciej Stachowiak 2006-04-02 23:36:23 PDT
Created attachment 7479 [details]
the fix is not so bad after all
Comment 7 Darin Adler 2006-04-03 08:41:38 PDT
Comment on attachment 7479 [details]
the fix is not so bad after all

I'm sad that nextKeyViewInFrame still needs to have a side effect.

That having been said, this looks like a pretty good fix.

r=me
Comment 8 Darin Adler 2006-04-03 08:44:01 PDT
Looks like Hyatt already reviewed this and Maciej already landed it last night.