Bug 67876 - [Chromium Win] 10% PLT regression r94589
Summary: [Chromium Win] 10% PLT regression r94589
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Mike Reed
URL: http://build.chromium.org/f/chromium/...
Keywords:
: 69239 (view as bug list)
Depends on:
Blocks: 69237
  Show dependency treegraph
 
Reported: 2011-09-09 16:53 PDT by Adam Barth
Modified: 2013-04-08 14:08 PDT (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2011-09-09 16:53:28 PDT
Something in this range:

http://trac.webkit.org/log/trunk?rev=94653&stop_rev=94560&verbose=on

Appears to have caused a 10% PLT regression:

http://build.chromium.org/f/chromium/perf/xp-release-dual-core/intl1/report.html?history=150&rev=100517

Notice the first spike when those revs were rolled into Chromium in Chromium@99936 and then the sustained rise after they were rolling in again in Chromium@100029.
Comment 1 Adam Barth 2011-09-09 17:11:57 PDT
I don't know whether this manifests on ports besides Chromium or on other test suites besides intl1.
Comment 2 Stephanie Lewis 2011-09-09 17:13:47 PDT
i'll check our tests on Monday.
Comment 3 Ilya Tikhonovsky 2011-09-12 08:22:46 PDT
(In reply to comment #2)
> i'll check our tests on Monday.

I've made some bisecting steps.

94619 - bad
94588 - good
Comment 4 Ilya Tikhonovsky 2011-09-12 09:55:46 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > i'll check our tests on Monday.
> 
> I've made some bisecting steps.
> 
> 94619 - bad
> 94588 - good

it is 94589


Author: reed@google.com <reed@google.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Tue Sep 6 19:21:52 2011 +0000

    [skia] never draw with GDI, so that all text can be gpu-accelerated
    https://bugs.webkit.org/show_bug.cgi?id=65203
    
    Reviewed by Kenneth Russell.
    
    Source/WebCore:
    
    * platform/graphics/chromium/FontChromiumWin.cpp:
    (WebCore::TransparencyAwareFontPainter::TransparencyAwareFontPainter::TransparencyAwareFontPainter):
    (WebCore::TransparencyAwareFontPainter::TransparencyAwareGlyphPainter::TransparencyAwareGlyphPainter):
    (WebCore::TransparencyAwareFontPainter::TransparencyAwareGlyphPainter::drawGlyphs):
    (WebCore::TransparencyAwareFontPainter::TransparencyAwareUniscribePainter::TransparencyAwareUniscribePainter):
    (WebCore::drawGlyphsWin):
    (WebCore::Font::drawComplexText):
    * platform/graphics/chromium/UniscribeHelper.cpp:
    (WebCore::UniscribeHelper::draw):
    * platform/graphics/skia/PlatformContextSkia.cpp:
    * platform/graphics/skia/PlatformContextSkia.h:
    * platform/graphics/skia/SkiaFontWin.cpp:
    (WebCore::skiaDrawText):
    * platform/graphics/skia/SkiaFontWin.h:
    
    LayoutTests:
    
    * platform/chromium/test_expectations.txt:
Comment 5 Adam Barth 2011-09-12 10:49:16 PDT
Would it make sense to roll out that patch while we investigate?  We don't want this perf regression to hide other problems.
Comment 6 Adam Barth 2011-09-12 10:50:23 PDT
(Just so others don't spend too long looking, this patch is after the M15 branch point.)
Comment 7 Jungshik Shin 2011-09-13 14:35:20 PDT
http://crbug.com/95748
Comment 8 Adam Barth 2011-09-27 10:00:09 PDT
What's the current status of this issue?  What the patch rolled out?  Was the performance regression fixed?
Comment 9 Adam Barth 2011-10-02 22:45:22 PDT
*** Bug 69239 has been marked as a duplicate of this bug. ***