Bug 67829 - REGRESSION(r94811): Assertion failure in 2 worker tests
Summary: REGRESSION(r94811): Assertion failure in 2 worker tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Mark Hahnenberg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-08 20:27 PDT by Ryosuke Niwa
Modified: 2011-09-08 23:06 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.80 KB, patch)
2011-09-08 22:03 PDT, Mark Hahnenberg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-09-08 20:27:37 PDT
The following 2 tests started hitting an assertion.
fast/workers/worker-close-more.html
fast/workers/use-machine-stack.html
Comment 4 Ryosuke Niwa 2011-09-08 20:33:53 PDT
Oops, I mistook build numbers for revision numbers.
Comment 5 Ryosuke Niwa 2011-09-08 21:32:52 PDT
I manually bisected and determined r94811 to be the cause.
Comment 6 Sam Weinig 2011-09-08 21:59:47 PDT
Looks like it is a missing &Base::s_info in exception classes I added.  Mark H. is going to land a fix for me.
Comment 7 Mark Hahnenberg 2011-09-08 22:03:40 PDT
Created attachment 106840 [details]
Patch
Comment 8 Sam Weinig 2011-09-08 22:04:58 PDT
Thanks Mark!
Comment 9 Ryosuke Niwa 2011-09-08 22:52:30 PDT
I have confirmed that this patch works and passes all the layout tests.

Thanks Mark!
Comment 10 Ryosuke Niwa 2011-09-08 23:06:16 PDT
Comment on attachment 106840 [details]
Patch

Clearing flags on attachment: 106840

Committed r94835: <http://trac.webkit.org/changeset/94835>
Comment 11 Ryosuke Niwa 2011-09-08 23:06:20 PDT
All reviewed patches have been landed.  Closing bug.