Bug 67706 - REGRESSION(r94288) build-webkit doesn't work on Symbian
Summary: REGRESSION(r94288) build-webkit doesn't work on Symbian
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Blocker
Assignee: Kristóf Kosztyó
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 38054
  Show dependency treegraph
 
Reported: 2011-09-07 05:46 PDT by Csaba Osztrogonác
Modified: 2011-09-07 06:33 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-09-07 05:46:53 PDT
cannot chdir to D:/t/qt-symbian-release/build/Source/WebKit from D:/t/qt-symbian-release/build/Source: No such file or directory, aborting. at D:/t/qt-symbian-release/build/Tools/Scripts/webkitdirs.pm line 1698

The problem is that qmake is called on Symbian from different path.
Comment 1 Csaba Osztrogonác 2011-09-07 05:48:05 PDT
It isn't so serious now, because trunk isn't buildable because of an RVCT bug. But it would be great if we can fix it tomorrow.
Comment 2 Csaba Osztrogonác 2011-09-07 06:33:15 PDT
I disabled clean build feature on Symbian, because it doesn't support shadow build. Because of this Source directory was removed instead of WebKitBuild.

Fix landed in http://trac.webkit.org/changeset/94667.

Making a clean build is more complex on Symbian. If Symbian folks are interested in this automatic clean build feature, ideas are welcome.