Bug 6769 - REGRESSION: Incomplete repaint when a cell's extra bottom margin grows
Summary: REGRESSION: Incomplete repaint when a cell's extra bottom margin grows
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar, Regression
: 7111 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-24 12:57 PST by mitz
Modified: 2006-05-06 04:31 PDT (History)
5 users (show)

See Also:


Attachments
Other testcase (472 bytes, text/html)
2006-01-24 13:02 PST, mitz
no flags Details
Patch, including change log and manual test (6.16 KB, patch)
2006-04-18 07:52 PDT, mitz
no flags Details | Formatted Diff | Diff
Updated patch, now with automated test (9.84 KB, patch)
2006-04-27 09:34 PDT, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-01-24 12:57:22 PST
In attachment 5911 [details], when you click Grow, there's an area that doesn't repaint, leaving behind a blue line. Switch to another tab to force repaint.

The Grow button eventually changes the cell's extra bottom, but when it repaints (during layout), it still has its old, smaller extra bottom, so it doesn't repaint any of the new area it will occupy. Most of that area is new to the table, so it gets painted by the table, but the blue area was already in the table and hence isn't repainted.

I'm going to attach another testcase, which is not a regression, where the table doesn't grow, and therefore nothing gets repainted.
Comment 1 mitz 2006-01-24 13:02:01 PST
Created attachment 5925 [details]
Other testcase
Comment 2 Darin Adler 2006-01-28 17:39:27 PST
It's an obvious coding mistake in JSAbstractEventListener::handleEvent.
Comment 3 Darin Adler 2006-01-28 17:41:20 PST
(In reply to comment #2)
> It's an obvious coding mistake in JSAbstractEventListener::handleEvent.

Oops, that was a comment for another bug!
Comment 4 mitz 2006-02-06 23:27:53 PST
See also bug 7111.
Comment 5 Alice Liu 2006-03-20 06:42:37 PST
Attachment 5911 [details] seems to be a regression but not attachment 5925 [details]

<rdar://problem/4483819>
Comment 6 mitz 2006-04-18 07:52:47 PDT
Created attachment 7801 [details]
Patch, including change log and manual test
Comment 7 Dave Hyatt 2006-04-20 00:21:23 PDT
I'll need time to study this one. :)
Comment 8 mitz 2006-04-23 13:09:43 PDT
Fixing bug 8449 made this bug appear also in manual-tests/left-overflow-repaint.html Test 3.
Comment 9 Darin Adler 2006-04-27 07:44:50 PDT
Looks good to me, but Hyatt said a week ago that he wants to look it over, so we should wait for him to review.
Comment 10 mitz 2006-04-27 09:34:00 PDT
Created attachment 8003 [details]
Updated patch, now with automated test

Corrected one mistake which Hyatt pointed out on IRC and changed the manual test into an automated one (which requires repaint.js from the patch in bug 8607).
Comment 11 Dave Hyatt 2006-04-27 23:48:54 PDT
Comment on attachment 8003 [details]
Updated patch, now with automated test

r=me (with trepidation!)
Comment 12 Alexey Proskuryakov 2006-05-06 04:31:41 PDT
*** Bug 7111 has been marked as a duplicate of this bug. ***