Bug 67662 - REGRESSION: Citibank Virtual Credit cards not functioning
Summary: REGRESSION: Citibank Virtual Credit cards not functioning
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Nobody
URL: https://www.accountonline.com/Athena/...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2011-09-06 12:08 PDT by malacca73
Modified: 2011-09-15 16:11 PDT (History)
2 users (show)

See Also:


Attachments
screenshot (34.19 KB, image/png)
2011-09-06 17:40 PDT, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description malacca73 2011-09-06 12:08:01 PDT
Citibank allows customers to create a virtual account number to use while shopping online. I use this  function frequently, and the latest couple of nightly builds seem to have broken this functionality. Specifically, when I go to sign in at the virtual credit card page, text cannot be entered in the text fields.
Comment 1 Alexey Proskuryakov 2011-09-06 16:26:31 PDT
<rdar://problem/10082027>
Comment 2 Alexey Proskuryakov 2011-09-06 16:30:59 PDT
Is this page available only to Citybank account holders? Or is there a way to reproduce this without being their client?
Comment 3 malacca73 2011-09-06 17:17:13 PDT
Anyone can access the link - you just need a Citibank card to login, so the problem should be apparent to anyone trying to enter any kind of text in either field.
Comment 4 Alexey Proskuryakov 2011-09-06 17:40:26 PDT
Created attachment 106526 [details]
screenshot

Interesting!

Is the page whose screenshot I'm attaching the right one? I can type there just fine when using nightly r94560.

What version of Adobe Flash do you have installed? Do you have Safari 5.1, or 5.0?
Comment 5 malacca73 2011-09-06 18:13:35 PDT
That is the correct screenshot.

I'm running  the latest nightly build of 5.1 - (6534.50, r94560) and Flash 10.3 r183. I didn't have this problem a few revisions ago, but I'm not sure which one exactly broke it. I do have the official Safari 5.1 release, and it works in that.
Comment 6 Alexey Proskuryakov 2011-09-07 10:38:27 PDT
We're having trouble reproducing this. Someone else at Apple could reproduce once, but it hasn't happened again.

Can you reproduce this if you restart Safari, and go straight to this URL, or does this depend on something else that you do prior to going there?
Comment 7 malacca73 2011-09-07 10:50:36 PDT
Just tried relaunching Safari, and it worked, so maybe it was something I was doing before. Hunh.