Bug 67513 - Add script that filters the output of build-webkit to be more human-readable
: Add script that filters the output of build-webkit to be more human-readable
Status: RESOLVED DUPLICATE of bug 44081
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Matthew Delaney
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-02 11:47 PDT by Matthew Delaney
Modified: 2011-09-06 15:44 PDT (History)
5 users (show)

See Also:


Attachments
Patch (8.71 KB, patch)
2011-09-02 14:00 PDT, Matthew Delaney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Delaney 2011-09-02 11:47:38 PDT
For at least on mac, the output of build-webkit is incredibly verbose. This makes finding build failures difficult either on your machine, or more importantly, on a mac EWS bot that normally has to truncate the build output log for whatever reason.

I've seen (and heard of) scripts floating around that filter the output to just show the important error details. These should be incorporated into the build-webkit script and be used on the bots. Hey, it might even shave off a little time per run on the bots to not have to hit the disk so much!
Comment 1 Eric Seidel 2011-09-02 12:14:32 PDT
I agree!  I used to even have one of such scripts...
Comment 2 Eric Seidel 2011-09-02 12:15:58 PDT
See also bug 15668.
Comment 3 Matthew Delaney 2011-09-02 13:03:18 PDT
Do you know why the logs are truncated on the mac build bots right now? Doing 'build-webkit | grep -v setenv' as kilzer suggests would be a super fast for the short term. Any chance we could throw that in there on the bots?
Comment 4 Matthew Delaney 2011-09-02 13:18:01 PDT
Nevermind, I've got a script that's awesome that's been floating around. I'll throw a patch up for it soon here.
Comment 5 Matthew Delaney 2011-09-02 14:00:48 PDT
Created attachment 106193 [details]
Patch
Comment 6 Joseph Pecoraro 2011-09-02 14:08:46 PDT
Duplicate? The patch is an updated version of the patch on:
<http://webkit.org/b/44081> build-webkit output could be easier to read in most situations
Comment 7 Eric Seidel 2011-09-02 14:11:27 PDT
Comment on attachment 106193 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=106193&action=review

> Tools/Scripts/filter-build-webkit:3
> +# Copyright (C) 2005, 2006, 2007, 2008, 2009, 2010, 2011 Apple Inc. All rights reserved.

Really?  You've been working on this script a long time!

> Tools/Scripts/filter-build-webkit:196
> +sub setLogileOption($$)

Logile?
Comment 8 Joseph Pecoraro 2011-09-02 14:12:39 PDT
Comment on attachment 106193 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=106193&action=review

> Tools/Scripts/filter-build-webkit:147
> +    elsif ($line =~ /^(PhaseScriptExecution|CompileC|Ld|PBXCp|CpResource|CopyPNGFile|CopyTiffFile|CpHeader|Processing|ProcessInfoPlistFile|ProcessPCH|ProcessPCH\+\+|Touch|Libtool|CopyStringsFile|Mig|CreateUniversalBinary) ("[^"]+"|\S+)/) {

I'd suggest "Analyze" here as well for clang's static analyzer.
Comment 9 Matthew Delaney 2011-09-02 14:20:47 PDT
For simplicity, I'm duping this against bug 44081 as Joe suggests since it has the old version patch of the script there with other ideas for it and how to incorporate it into the actual build-webkit script.

*** This bug has been marked as a duplicate of bug 44081 ***
Comment 10 Eric Seidel 2011-09-06 15:44:58 PDT
Comment on attachment 106193 [details]
Patch

Cleared review? from attachment 106193 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).