Bug 67398 - [GTK] two a11y tests failing
: [GTK] two a11y tests failing
Status: RESOLVED DUPLICATE of bug 73746
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-01 07:18 PDT by Philippe Normand
Modified: 2011-12-03 10:18 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2011-09-01 07:18:45 PDT
--- /home/slave/webkitgtk/gtk-linux-64-debug/build/layout-test-results/platform/gtk/accessibility/combo-box-collapsed-selection-changed-expected.txt 
+++ /home/slave/webkitgtk/gtk-linux-64-debug/build/layout-test-results/platform/gtk/accessibility/combo-box-collapsed-selection-changed-actual.txt 
@@ -26,8 +26,6 @@
 Accessibility object emitted "state-change:selected = 1" / Name: "foo" / Role: 34
 Accessibility object emitted "focus-event = 1" / Name: "foo" / Role: 34
 Accessibility object emitted "state-change:focused = 1" / Name: "foo" / Role: 34
-Accessibility object emitted "load-complete" / Name: "(No name)" / Role: 80
-Accessibility object emitted "state-change:busy = 0" / Name: "(No name)" / Role: 80
 
 This tests that the 'state-changed:selected' signal is emitted when arrowing through the options of a combobox while collapsed.
 


--- /home/slave/webkitgtk/gtk-linux-64-debug/build/layout-test-results/platform/gtk/accessibility/document-reload-events-expected.txt 
+++ /home/slave/webkitgtk/gtk-linux-64-debug/build/layout-test-results/platform/gtk/accessibility/document-reload-events-actual.txt 
@@ -3,8 +3,6 @@
 Accessibility object emitted "state-change:busy = 1" / Name: "(No name)" / Role: 80
 Accessibility object emitted "reload" / Name: "(No name)" / Role: 80
 Accessibility object emitted "state-change:defunct = 1" / Name: "(No name)" / Role: 80
-Accessibility object emitted "load-complete" / Name: "(No name)" / Role: 80
-Accessibility object emitted "state-change:busy = 0" / Name: "(No name)" / Role: 80
 Test that AtkDocument emits the right signals when reloading.
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".

Failures are consistent on the 3 bots. Will skip for now.
Comment 1 Mario Sanchez Prada 2011-12-03 10:18:07 PST
The root problem of this is that document-related events (loading, reloading) shouldn't be logged in the DRT, and just checked through regular unit tests.

So, marking as duplicate of bug 73746.

*** This bug has been marked as a duplicate of bug 73746 ***