Bug 6733 - REGRESSION: html input doesn't honor change to value
Summary: REGRESSION: html input doesn't honor change to value
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Darin Adler
URL:
Keywords:
: 6776 7136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-23 08:23 PST by Dennis Rowe
Modified: 2006-02-08 11:16 PST (History)
3 users (show)

See Also:


Attachments
Reduced example of bug (238 bytes, text/html)
2006-01-23 08:23 PST, Dennis Rowe
no flags Details
Don't go through QString (1.36 KB, patch)
2006-01-23 09:04 PST, mitz
no flags Details | Formatted Diff | Diff
Updated patch (1.49 KB, patch)
2006-01-23 09:06 PST, mitz
darin: review+
Details | Formatted Diff | Diff
Trying to fix the DOMString::qstring problem as well (1.99 KB, patch)
2006-01-23 09:46 PST, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Rowe 2006-01-23 08:23:06 PST
When I have a input field with a predefined value, and I change that value, the POST or GET does not honor that change.  I have attached an example of the reduced problem.  Here is how to reproduce the problem.

1. Load attached html in to test.html
2. Load in to Safari
3. Highlight and delete "2020-01-01 00:00:00" in the input field
4. "Submit"
5. Look in the URL bar, and you will see the "content" part of the URL holds the old data and not the new data.

The problem occurs on the nightly build but not on Version 2.0.3 (417.8) of Safari on OSX 10.4.
Comment 1 Dennis Rowe 2006-01-23 08:23:48 PST
Created attachment 5876 [details]
Reduced example of bug

Reduced version of bug.
Comment 2 Joost de Valk (AlthA) 2006-01-23 08:30:10 PST
Confirmed, this is a critical issue.
Comment 3 mitz 2006-01-23 09:04:07 PST
Created attachment 5877 [details]
Don't go through QString

I don't think an automated test is possible, much like in bug 6221.
Comment 4 mitz 2006-01-23 09:06:32 PST
Created attachment 5878 [details]
Updated patch

Added bug # to the ChangeLog entry
Comment 5 Darin Adler 2006-01-23 09:07:28 PST
Comment on attachment 5878 [details]
Updated patch

Good local fix, but I don't understand why an empty DOMString turns into a null DOMString when round tripping to QString.

That should be fixed too.

r=me
Comment 6 mitz 2006-01-23 09:46:16 PST
Created attachment 5879 [details]
Trying to fix the DOMString::qstring problem as well

I think it's OK to fix it under this bug. Not sure the fix is optimal.
Comment 7 Darin Adler 2006-01-23 11:41:40 PST
Comment on attachment 5879 [details]
Trying to fix the DOMString::qstring problem as well

Nice. r=me
Comment 8 Darin Adler 2006-01-23 19:32:48 PST
I'll land this one.
Comment 9 Dennis Rowe 2006-01-24 11:48:57 PST
I downloaded the source and compiled it and tested it against the reduced test case and also against the case that the reduced test came from.  In both cases the new patch worked as it should. Thanks!
Comment 10 mitz 2006-01-24 14:21:49 PST
*** Bug 6776 has been marked as a duplicate of this bug. ***
Comment 11 Eric Seidel (no email) 2006-01-31 21:20:57 PST
Removing Regression keyword from bugs already fixed.
Comment 12 Joost de Valk (AlthA) 2006-02-08 11:16:42 PST
*** Bug 7136 has been marked as a duplicate of this bug. ***