Bug 67321 - [CSS3 Backgrounds and Borders] Implement border-image-slice
Summary: [CSS3 Backgrounds and Borders] Implement border-image-slice
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on:
Blocks: 27583
  Show dependency treegraph
 
Reported: 2011-08-31 14:33 PDT by Dave Hyatt
Modified: 2011-09-06 14:45 PDT (History)
8 users (show)

See Also:


Attachments
Patch (91.09 KB, patch)
2011-08-31 14:49 PDT, Dave Hyatt
bdakin: review+
webkit-ews: commit-queue-
Details | Formatted Diff | Diff
New patch to test out EWS etc. (127.12 KB, patch)
2011-08-31 19:17 PDT, Dave Hyatt
webkit-ews: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2011-08-31 14:33:14 PDT
This bug is tracking the implementation of the border-image-slice property.
Comment 1 Dave Hyatt 2011-08-31 14:49:24 PDT
Created attachment 105833 [details]
Patch
Comment 2 WebKit Review Bot 2011-08-31 14:53:35 PDT
Attachment 105833 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast..." exit_code: 1

LayoutTests/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Source/WebCore/css/CSSBorderImageValue.h:58:  The parameter name "slice" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/css/CSSParser.h:39:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/WebCore/css/CSSParser.h:170:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSStyleSelector.cpp:5733:  l is incorrectly named. Don't use the single letter 'l' as an identifier name.  [readability/naming] [4]
Source/WebCore/css/CSSBorderImageSliceValue.h:47:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Source/WebCore/css/CSSParser.cpp:5296:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.cpp:5360:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 8 in 30 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Early Warning System Bot 2011-08-31 15:33:15 PDT
Comment on attachment 105833 [details]
Patch

Attachment 105833 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/9572676
Comment 4 Beth Dakin 2011-08-31 15:44:20 PDT
Comment on attachment 105833 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=105833&action=review

r=me! Dave mentioned on irc that he fixed all of the style issues except the RefPtr thing, which there is an open question about. Either way, parseBorderImage (which already exists in the codebase) does the same thing, so it's probably okay to check some more similar code in while Dave's figuring out the right thing.

> Source/WebCore/css/CSSParser.cpp:5318
> +    PassRefPtr<CSSBorderImageSliceValue> commitBorderImageSlice()

I feel like some comments would be nice in this function. I think I can make out why m_top is asserted and why m_bottom and m_left are set if there is no m_right by looking at the patch as a whole, but some comments would be nice so that it's less mysterious out of context.
Comment 5 WebKit Review Bot 2011-08-31 16:13:56 PDT
Comment on attachment 105833 [details]
Patch

Attachment 105833 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/9565957

New failing tests:
fast/gradients/border-image-gradient-sides-and-corners.html
fast/css/getComputedStyle/computed-style-without-renderer.html
svg/css/getComputedStyle-basic.xhtml
fast/css/getComputedStyle/computed-style.html
fast/reflections/reflection-computed-style.html
fast/borders/border-image-slices.html
Comment 6 Dave Hyatt 2011-08-31 19:17:00 PDT
Created attachment 105883 [details]
New patch to test out EWS etc.
Comment 7 WebKit Review Bot 2011-08-31 19:20:54 PDT
Attachment 105883 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast..." exit_code: 1

Last 3072 characters of output:
ved.  [readability/parameter_name] [5]
Source/WebCore/css/CSSParser.h:148:  The parameter name "rgb" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/css/CSSParser.h:169:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:170:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:178:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:180:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:181:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:182:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:186:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:186:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:186:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:187:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:187:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:225:  The parameter name "marginBox" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/css/CSSParser.h:309:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/css/CSSParser.h:323:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/css/CSSParser.h:327:  yy_c_buf_p is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/CSSParser.h:328:  yy_hold_char is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/CSSParser.h:329:  yy_last_accepting_state is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/CSSParser.h:330:  yy_last_accepting_cpos is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/CSSParser.h:333:  yy_start is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/CSSParser.h:357:  One space before end of line comments  [whitespace/comments] [5]
Source/WebCore/css/CSSParser.h:367:  Missing spaces around |  [whitespace/operators] [3]
Source/WebCore/css/CSSParser.cpp:5360:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 41 in 31 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 8 Dave Hyatt 2011-08-31 19:23:49 PDT
LOL so fixing CSSParser's indentation namespace problem just exposes me to a zillion style errors. I give up.
Comment 9 Early Warning System Bot 2011-08-31 19:47:03 PDT
Comment on attachment 105883 [details]
New patch to test out EWS etc.

Attachment 105883 [details] did not pass qt-ews (qt):
Output: http://queues.webkit.org/results/9578199
Comment 10 WebKit Review Bot 2011-08-31 20:07:44 PDT
Comment on attachment 105883 [details]
New patch to test out EWS etc.

Attachment 105883 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/9578208

New failing tests:
svg/css/getComputedStyle-basic.xhtml
fast/css/getComputedStyle/computed-style.html
fast/borders/border-image-slices.html
fast/css/getComputedStyle/computed-style-without-renderer.html
Comment 11 Collabora GTK+ EWS bot 2011-08-31 20:47:02 PDT
Comment on attachment 105833 [details]
Patch

Attachment 105833 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/9570862
Comment 12 Collabora GTK+ EWS bot 2011-08-31 22:46:24 PDT
Comment on attachment 105883 [details]
New patch to test out EWS etc.

Attachment 105883 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/9570899
Comment 13 Csaba Osztrogonác 2011-09-01 10:24:56 PDT
Original patch landed in http://trac.webkit.org/changeset/94299

And I had to fix the Qt build ( http://trac.webkit.org/changeset/94304 ) , because Dave was too lazy to respect WebKit policies and fix the build before and after landing ... :(
Comment 16 Dave Hyatt 2011-09-06 14:45:10 PDT
Fixed.