Bug 67244 - Add additional convertValue overloads to JSDictionary
Summary: Add additional convertValue overloads to JSDictionary
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sam Weinig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 16:21 PDT by Sam Weinig
Modified: 2011-08-30 16:33 PDT (History)
1 user (show)

See Also:


Attachments
Patch (5.24 KB, patch)
2011-08-30 16:23 PDT, Sam Weinig
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Weinig 2011-08-30 16:21:09 PDT
Add additional convertValue overloads to JSDictionary
Comment 1 Sam Weinig 2011-08-30 16:23:58 PDT
Created attachment 105716 [details]
Patch
Comment 2 WebKit Review Bot 2011-08-30 16:26:07 PDT
Attachment 105716 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/bindings/js/JSDictionary.cpp:34:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebCore/bindings/js/JSDictionary.cpp:98:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.cpp:103:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.cpp:108:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.cpp:113:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.h:70:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.h:71:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.h:72:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/bindings/js/JSDictionary.h:73:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 9 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2011-08-30 16:33:38 PDT
Committed r94123: <http://trac.webkit.org/changeset/94123>