Bug 6710 - get animateTransform to work
Summary: get animateTransform to work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P3 Normal
Assignee: Nobody
URL: http://www.bjoernsworld.de/temp/svg-w...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2006-01-22 02:54 PST by Eric Seidel (no email)
Modified: 2009-10-05 08:34 PDT (History)
4 users (show)

See Also:


Attachments
Testcase (1.02 KB, image/svg+xml)
2006-02-04 09:59 PST, Joost de Valk (AlthA)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-01-22 02:54:27 PST
SVG renders completely black

See URL.  We'll need to reduce this one.
Comment 1 Joost de Valk (AlthA) 2006-02-04 09:58:53 PST
I'll attach a testcase, but this boils down to animateTransform not working. Eric pointed out on IRC that this had been disabled because it was causing crashes.

Comment 2 Joost de Valk (AlthA) 2006-02-04 09:59:14 PST
Created attachment 6248 [details]
Testcase
Comment 3 Eric Seidel (no email) 2007-01-31 04:49:25 PST
well animateTransform works partially, but not well enough for this SVG it seems.
Comment 4 Gavin Sherlock 2008-08-01 06:11:40 PDT
The bug url (redirects to http://www.websitedev.de/temp/svg-wg-appreciation-day.svgz) seems to work for me, though I don't know exactly how it's supposed to look.  Tested with r35417.

The testcase shows nothing though...
Comment 5 Nikolas Zimmermann 2009-10-05 08:34:43 PDT
Works just as expected in ToT. Closing.