Bug 66769 - Web Inspector: rename sourceFile to (raw|ui)SourceCode in DebuggerPresentationModel.
Summary: Web Inspector: rename sourceFile to (raw|ui)SourceCode in DebuggerPresentatio...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Podivilov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-23 06:01 PDT by Pavel Podivilov
Modified: 2011-08-29 08:14 PDT (History)
10 users (show)

See Also:


Attachments
Patch (38.09 KB, patch)
2011-08-23 06:02 PDT, Pavel Podivilov
no flags Details | Formatted Diff | Diff
Patch (41.21 KB, patch)
2011-08-25 07:18 PDT, Pavel Podivilov
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Podivilov 2011-08-23 06:01:00 PDT
Web Inspector: rename sourceFile to (raw|ui)SourceCode in DebuggerPresentationModel.

Rename sourceFile to (raw|ui)SourceCode and store RawSourceCode and UISourceCode instances in separate maps.
This is the last step before actually switching to RawSourceCode<->UISourceCode scheme (currently only RawSourceCode is used).
Comment 1 Pavel Podivilov 2011-08-23 06:02:33 PDT
Created attachment 104831 [details]
Patch
Comment 2 Pavel Feldman 2011-08-25 00:12:59 PDT
Comment on attachment 104831 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=104831&action=review

> Source/WebCore/inspector/front-end/DebuggerPresentationModel.js:36
> +    this._uiSourceCode = {};

I thought ui source code items belong to corresponding raw source code items.

> Source/WebCore/inspector/front-end/SourceFile.js:77
> +        uiLocation.uiSourceCode = this;

Defining class for UILocation would help understanding the code.
Comment 3 Pavel Podivilov 2011-08-25 07:18:22 PDT
Created attachment 105181 [details]
Patch
Comment 4 Pavel Podivilov 2011-08-25 07:19:02 PDT
Please take another look.

(In reply to comment #2)
> (From update of attachment 104831 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=104831&action=review
> 
> > Source/WebCore/inspector/front-end/DebuggerPresentationModel.js:36
> > +    this._uiSourceCode = {};
> 
> I thought ui source code items belong to corresponding raw source code items.

Agree.

> 
> > Source/WebCore/inspector/front-end/SourceFile.js:77
> > +        uiLocation.uiSourceCode = this;
> 
> Defining class for UILocation would help understanding the code.

Done.
Comment 5 Pavel Podivilov 2011-08-29 08:14:36 PDT
Committed r93977: <http://trac.webkit.org/changeset/93977>