Bug 66436 - --webkit-visual-word renaming right/leftWordPositionAcrossBoundary
Summary: --webkit-visual-word renaming right/leftWordPositionAcrossBoundary
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 25298
  Show dependency treegraph
 
Reported: 2011-08-17 17:29 PDT by Xiaomei Ji
Modified: 2011-08-18 16:06 PDT (History)
3 users (show)

See Also:


Attachments
patch (2.62 KB, patch)
2011-08-17 18:09 PDT, Xiaomei Ji
rniwa: review-
Details | Formatted Diff | Diff
patch (2.63 KB, patch)
2011-08-18 14:55 PDT, Xiaomei Ji
rniwa: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xiaomei Ji 2011-08-17 17:29:12 PDT
Those 2 function names are confusing.
They are actually returning right/left word position ignore editable boundary.

Rename them to right/leftWordPositionIgnoreEditableBoundary.
Comment 1 Xiaomei Ji 2011-08-17 18:09:21 PDT
Created attachment 104289 [details]
patch
Comment 2 Ryosuke Niwa 2011-08-17 20:23:31 PDT
Comment on attachment 104289 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=104289&action=review

> Source/WebCore/editing/visible_units.cpp:1598
> +static VisiblePosition leftWordPositionIgnoreEditableBoundary(const VisiblePosition& visiblePosition)

We normally use AcrossEditingBoundary instead of IgnoringEditingBoundary.
Comment 3 Xiaomei Ji 2011-08-18 09:26:33 PDT
(In reply to comment #2)
> (From update of attachment 104289 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=104289&action=review
> 
> > Source/WebCore/editing/visible_units.cpp:1598
> > +static VisiblePosition leftWordPositionIgnoreEditableBoundary(const VisiblePosition& visiblePosition)
> 
> We normally use AcrossEditingBoundary instead of IgnoringEditingBoundary.

ap commented in issue 65277 (https://bugs.webkit.org/show_bug.cgi?id=65277#c32) that
"Both names mean that the result will always be across boundary, which is apparently untrue.".

So, I am changing "Across" to "Ignoring" which means it ignores editing boundary, could return a position inside editing boundary or across editing boundary.
Comment 4 Ryosuke Niwa 2011-08-18 14:16:07 PDT
(In reply to comment #3)
> ap commented in issue 65277 (https://bugs.webkit.org/show_bug.cgi?id=65277#c32) that
> "Both names mean that the result will always be across boundary, which is apparently untrue.".
>
> So, I am changing "Across" to "Ignoring" which means it ignores editing boundary, could return a position inside editing boundary or across editing boundary.

Okay.  I agree with ap on second thought so let's rename these to IgnoringEditingBoundary (NOT IgnoreEditingBoundary).
Comment 5 Xiaomei Ji 2011-08-18 14:55:30 PDT
Created attachment 104400 [details]
patch
Comment 6 Xiaomei Ji 2011-08-18 16:06:02 PDT
Committed r93368: <http://trac.webkit.org/changeset/93368>