Bug 66156 - Switch RenderBox to to new layout types
Summary: Switch RenderBox to to new layout types
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Emil A Eklund
URL:
Keywords:
Depends on:
Blocks: 63567
  Show dependency treegraph
 
Reported: 2011-08-12 12:34 PDT by Emil A Eklund
Modified: 2011-08-17 23:37 PDT (History)
4 users (show)

See Also:


Attachments
Patch (64.40 KB, patch)
2011-08-12 17:02 PDT, Emil A Eklund
no flags Details | Formatted Diff | Diff
Patch (67.02 KB, patch)
2011-08-12 18:33 PDT, Emil A Eklund
no flags Details | Formatted Diff | Diff
Patch (67.04 KB, patch)
2011-08-15 17:22 PDT, Emil A Eklund
no flags Details | Formatted Diff | Diff
Patch for landing (66.88 KB, patch)
2011-08-17 13:41 PDT, Emil A Eklund
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Emil A Eklund 2011-08-12 12:34:11 PDT
Convert *** to new layout abstraction as a part of the ongoing conversion work.
Comment 1 Emil A Eklund 2011-08-12 17:02:49 PDT
Created attachment 103844 [details]
Patch
Comment 2 WebKit Review Bot 2011-08-12 17:33:05 PDT
Comment on attachment 103844 [details]
Patch

Attachment 103844 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/9378061

New failing tests:
fast/block/float/overhanging-tall-block.html
Comment 3 Emil A Eklund 2011-08-12 17:37:49 PDT
The test overhanging-tall-block.html seems to be missing expected results for cr-linux.

Will investigate before I submit but please go ahead and review.
Comment 4 Emil A Eklund 2011-08-12 17:40:04 PDT
Actually, the output suggests that the failing test is the following rather than the float test.

Regressions: Unexpected image and text mismatch : (1)
  svg/custom/svg-fonts-word-spacing.html = IMAGE+TEXT

Looking into why now.
Comment 5 Emil A Eklund 2011-08-12 18:33:54 PDT
Created attachment 103851 [details]
Patch
Comment 6 Emil A Eklund 2011-08-15 17:22:23 PDT
Created attachment 103984 [details]
Patch
Comment 7 Eric Seidel (no email) 2011-08-17 11:30:56 PDT
Comment on attachment 103984 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=103984&action=review

> Source/WebCore/rendering/RenderBox.cpp:1151
> +    LayoutRect clipRect(location + LayoutSize(borderLeft(), borderTop()),

Isn't this borderRect().location?

> Source/WebCore/rendering/RenderBox.cpp:1864
> -            logicalHeight = h.value();
> +            logicalHeight = h.calcFloatValue(0);

Why?
Comment 8 Emil A Eklund 2011-08-17 12:34:57 PDT
(In reply to comment #7)
> (From update of attachment 103984 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=103984&action=review
> 
> > Source/WebCore/rendering/RenderBox.cpp:1151
> > +    LayoutRect clipRect(location + LayoutSize(borderLeft(), borderTop()),
> 
> Isn't this borderRect().location?

No, borderBoxRect.location is in the local coordinate space (i.e. does not include the location offset).

> 
> > Source/WebCore/rendering/RenderBox.cpp:1864
> > -            logicalHeight = h.value();
> > +            logicalHeight = h.calcFloatValue(0);
> 
> Why?

Good catch, reverted.
Comment 9 Emil A Eklund 2011-08-17 13:41:41 PDT
Created attachment 104227 [details]
Patch for landing
Comment 10 WebKit Review Bot 2011-08-17 23:37:37 PDT
Comment on attachment 104227 [details]
Patch for landing

Rejecting attachment 104227 [details] from commit-queue.

Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=ec2-cq-03', '--port..." exit_code: 2

Last 500 characters of output:
.
creating empty directory: LayoutTests/platform/chromium-mac-leopard
creating empty directory: LayoutTests/platform/chromium-mac/fast/events
creating empty directory: LayoutTests/platform/chromium-mac/http/tests/workers
creating empty directory: LayoutTests/platform/chromium-mac/storage/domstorage
Updating chromium port dependencies using gclient...

________ running '/usr/bin/python gyp_webkit' in '/mnt/git/webkit-commit-queue/Source/WebKit/chromium'
Updating webkit projects from gyp files...

Full output: http://queues.webkit.org/results/9423376
Comment 11 WebKit Review Bot 2011-08-17 23:37:45 PDT
Comment on attachment 104227 [details]
Patch for landing

Clearing flags on attachment: 104227

Committed r93284: <http://trac.webkit.org/changeset/93284>
Comment 12 WebKit Review Bot 2011-08-17 23:37:50 PDT
All reviewed patches have been landed.  Closing bug.