REOPENED 66121
Rename GraphicsContextGL::paintToCanvas() to a more generic name
https://bugs.webkit.org/show_bug.cgi?id=66121
Summary Rename GraphicsContextGL::paintToCanvas() to a more generic name
John Bauman
Reported 2011-08-11 18:26:27 PDT
This is referenced in GraphicsContext3D::paintRenderingResultsToCanvas, which is a layering violation. It would be pretty easy to replace this with the canvas's ImageBuffer in these circumstances.
Attachments
Anne van Kesteren
Comment 1 2024-09-03 11:49:44 PDT
I can no longer find that method.
Said Abou-Hallawa
Comment 2 2024-09-04 09:45:03 PDT
GraphicsContext3D was renamed to GraphicsContextGL in 218939@main. But GraphicsContextGL still has a static method called GraphicsContextGL::paintToCanvas(). This method does not do anything specific to the canvas or to the GraphicsContextGL itself. It just draws a NativeImage to a GraphicsContext. I think function should be removed from this class and should be renamed to a more generic name. Also this function has this code which I think is valid only for Cocoa platforms: GraphicsContextStateSaver stateSaver(context); context.scale(FloatSize(1, -1)); context.translate(0, -imageSize.height());
Note You need to log in before you can comment on or make changes to this bug.